Skip to Content
avatar image
Former Member

Report with Shared Axist with no data still appears

Hi,

I have two reports on SAP BPC 10 and they share the same axis. I have found that even if the reports have no data they still show one line with the name of the top node with zeros. This is even if I have set the report to suppress zero and no values in the rows - is this normal?

That is does a report which has no data always show one line even if it is set to suppress rows if zero?

Thanks,

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Dec 25, 2014 at 08:27 AM

    Hi Leo,

    Just tested...

    Even if you suppress empty and zero values one line per report will be present. But the mentioned lines will be hidden!

    Vadim

    Add comment
    10|10000 characters needed characters exceeded

    • Interesting finding:

      I have created 2 reports with shared page and column axis (with no data):

      First report shows parent NETSALESADVCASH and children, second - parent 0 and children.

      If I suppress zero and empty for rows using sheet options the result will be:

      with hidden rows 8 and 9.

      If I unhide rows:

      I will see same parents for both reports!

      The same picture will be if I suppress zero and empty rows individually for each report.

      B.R. Vadim

  • avatar image
    Former Member
    Dec 24, 2014 at 05:18 PM

    Hi Leo,

    Please run Light optimization.

    light optimization Closes the open request, compresses without Zero-Elimination and indexes the cube, and updates database statistics for the BW InfoCube.


    for light optimization you refer below link


    http://scn.sap.com/community/epm/planning-and-consolidation-for-netweaver/blog/2014/05/02/full-optimization-and-light-optimization-in-detail


    BPC Light Optimize Configuration


    Lite Optimize - A little guide to the big things you should know



    also check report specific options.If enable then from that option use suppress zero.


    select report (default or 001) Edit report ==> options==> suppress zero



    Regards

    Sushant

    Add comment
    10|10000 characters needed characters exceeded