Skip to Content
avatar image
Former Member

Input control issue - RWI 00011

Hi guys,

I am facing issue in input control. I am using BO 4.1 SP3, but i've tested it on SP5 too with same result (no patches on both environments).

I have report with 1 table and i am using search input control (for example on column A) described in this blog http://blog.davidg.com.au/2012/04/search-field-input-control-in-webi.html and other multiple choise input controls (check boxes) on columns B, C etc.

When i schedule report, first time user opens it and uses search input control, everything is fine. User closes report, opens it again and uses search input control and nothing happen - table is not filtered at all, user cannot user check box input control. Issue is not present:

  1. after publishing new report instance (for the first time user runs report instance)
  2. when user uses check box input control first
  3. when user uses button to reset input control first (immediately after report instance is opened)
  4. when i change checkbox input control to non-multiple choice input control (ie radio button)

In addition when I use checkbox input control using variable, on second run of the instance and use of search input control, error RWI 00011 is poped up.

To test it you can follow these steps:

  1. create new webi report using eFashion universe (or you can use your own and replace columns)
  2. On query pane add these objects: Product -> Lines and Store -> City. Run query
  3. New table is created with two objects (Lines and City)
  4. Create new variable "Search City" using formula =""
  5. Create new variable "Search City Matchees" using formula =If Pos(Upper([City]);Upper([Search City]))>0 Then "Yes" Else "No"
  6. Add variable "Search City Matches" as third column in table
  7. Add table filter "Search City Matches" equals "Yes"
  8. Add input control using variable "Search City". Variable type is Input field and operator is Equals
  9. Add another input control using "Lines" object. Input control type is Check box, you can use default values and in dependencies use it on table block.
  10. Save report.
  11. Close report
  12. Schedule report to run now.
  13. Open report (open last instance)
  14. Use input field in input control and write ie "lora" (without quotas). Only Colorado Springs is selected.
  15. Close report without saving and open it again.
  16. Use input field in input control and write ie "lora" (without quotas). Filter is not applied.

To get RWI 00011 error performe these steps in addition.

  1. create variable "Lines var" using formula =[Lines] and add it to table as 4th column.
  2. create new input control using "Lines var" variable. Input control type is Check box, you can use default values and in dependencies use it on table block.
  3. Repeat steps 10 to 16.

Any idea how to solve this issue? Any workaround? Is this issue present on your environment?

Regards

Tomáš


ErrorCapture.JPG (15.0 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Dec 24, 2014 at 04:56 PM

    Hi,

    Have you tested from other browsers?

    Have you tested deleting webi and application server cache as described by those KBAs:

    1207029 - How To Clear The Web Intelligence Report Cache

    1879431 - How to clear the Tomcat cache directory?

    Kind regards,

    Wafa

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Tested on 3 different environments (2x SAP BO 4.1 SP3 and 1x SAP BO 4.1 SP5) using IE10, Google Chrome, Firefox. I have cleared tomcat cache with no effect. I've tried it using WACS but error persists.

      Clearing WebI cache is good hint. After cleaning it report instance behave like i run it for the first time - without error. Second time i run it, error is back again. So it must be related with WebI cache. Helpful Answer for you Wafa.

      Tomáš

  • Dec 24, 2014 at 06:15 PM

    I reproduced these quite easily with your steps.

    It appears to only happen in the HTML viewer so changing your default View viewer from HTML to Applet is a work-around.

    Another thing I notices is that if you search for the first part of a City first, it seems to work fine after that.

    For example, if  you use "Aust" instead of "lora" for your search city, then it works and filters on Aust.  Subsequent searches for "lora" work after that.

    It looks to be a defect though and you should open up an incident with SAP Support and reference this post.  Support can fire it off to a developer in the Webi HTML viewer team to look into it at a code level.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Wafa,

      thank you for testing on the newest environment. As workaround, I've turned webi document caching off. There is low utilization of our server so i do not expect performance issues.

      I am still waiting for someone with rights to open incident, but nobody is working this week.

      Tomáš

  • Sep 09, 2015 at 01:54 PM

    HI All,

    Any news here?  I am seeing this issue on 4.1 SP4 patch 6.   If it has been fixed in a more current SP/patch.. that would be great to note here.

    I will look at the notes/work arounds.

    thanks

    james

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      We are in a customer where we are using SAP BO 4.1 SP5, patch level 7 and I see this error message. I have rebuilt the entire webi report and this error message desapeared. But now, there is another problem that maybe it is related to this first error message.

      The problem is that when I open the report for the first time and change the input control it works fine, but if I close the report and open it again, the first time I change the options in the input control, the report does not respect the choice (nothing happens). Then, If I change the same input control to another option and get back to the first one, then the report works fine.

      I found this note (2171190) :

      2171190 - In HTML viewer, custom input control does not works for the first time however with second selection of lov it works perfectly fine


      But this note does not have a solution yet. Does anyone knows if this issue has been fixed ? It seems to be a issue with the HTML viewer. If I change it to Applet, as mentioned in this blog, then it works fine.


      Regards,

      Andre