Skip to Content
avatar image
Former Member

Add rows to cube where all key figures have zero values

Hi All,

I am loading data from DSO to Cube, but what I am observing is that wherever there is 0 values for all key figures in a row then it is not getting inserted into the cube. That row is getting skipped. Is it a normal behavior of a cube or there is something I need to check. I have written Start routine and end routine in transformation which maps DSO to Cube. Please suggest.

Thanks,

Avadhoot Nayakal

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Dec 24, 2014 at 03:06 PM

    Hi Avadhoot,

    Suppose to not, it has to update record.

    May be you written any logic like deleting rows where all key figures are zero (0).

    Pls check.

    Or

    Create another infocube cube2 and create transformation from same dso which feeding actual one,

    in this transformation do not write any logic just update and check how it is working.

    Regards,

    Nanda

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 24, 2014 at 03:57 PM

    Hi Avandhoot!

    Please check if you have any init or final routine. Another case maybe you are running a compresiĆ³n process in your cube.

    Regards.

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 24, 2014 at 04:34 PM

    hi avadhoot,

                       it must and should update can you check the code of your routine.

    Add comment
    10|10000 characters needed characters exceeded