Skip to Content
avatar image
Former Member

Role Owner not found detour

Hi guys and girls,

Merry Christmas, happy holidays and fun times.  My issue is interesting because I had it working.  I don't believe I changed much to break it and now, it's not working.

First - here's a screenshot of the successful run.  As you can see, the detour path worked.  Let me elaborate on what I'm doing.

I have a path for production requests.  My BRF+ flat line rule works so that requests for production go into this path.  In this path are two stages.  First stage is manager, and if there are SoDs, then there is a detour path.  I had tested this before and it had worked, and it hasn't been touched, so I don't see why it should have stopped working.

The second stage is for role approval.  If a role doesn't have an approver, it should be auto approved.  I have used the GRAC_MSMP_ROUTE_NO_ROLEOWNER detour in the stage to send it to a path with no stages in it for auto approval.

As indicated from the above screenshot, this has worked.  However, it stopped working.  Below are screenshots of my config.  Please let me know if you see something that I'm missing as I've been looking at this for too long now.

Under step 1 - Process Global Settings, I have two escape paths.

Under step 5 - I have the following configured.  I have selected my production path for this discussion.  Below, for stage 010 - ZMANAGER, I have an SoD detour set.

For stage 020 - ZROLEAPPR, I have a role approver not found detour and also an escalation setup to the role alternate approver.  This was the case before when the initial screenshot above was taken.

Here's the modify task settings for the ZROLEAPPR.

Now here's what happens when I create a request.  It fails and goes to the escape route.

So now I'm not sure what I changed because it's looking exactly like what I had setup when I had it working.

Thanks,

Santosh

Capture.PNG (56.9 kB)
Capture1.PNG (11.9 kB)
Capture2.PNG (45.4 kB)
Capture3.PNG (63.3 kB)
Capture4.PNG (31.3 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Dec 23, 2014 at 11:29 PM

    I wanted to add that I've turned on debugging.  Here's something i saw in the debug log.

    It says Approver not found, but it doesn't take the detour.


    Capture5.PNG (57.3 kB)
    Add comment
    10|10000 characters needed characters exceeded