Skip to Content
avatar image
Former Member

SAP Server does not start after Windows Upgrade

Hi

After the Windows Server Udpate from Windows Server 2003 to Windows Server 2008 R2 Enterprise the SAP Netweaver CE 7.2 SPS09 does not start. The dev_enqsrv shows following:

---------------------------------------------------

trc file: "dev_enqsrv", trc level: 1, release: "720"

---------------------------------------------------

[Thr 5068] Tue Dec 23 19:35:36 2014

[Thr 5068] stopAllThreads: stop Thread worker thread ...[Thr 5068] done

[Thr 5068] stopAllThreads: stop Thread Listener thread ...[Thr 5068] done

[Thr 5068] stopAllThreads: stop Thread IOThread_0 ...[Thr 5068] done

[Thr 5068] stopAllThreads: stop Thread IOThread_1 ...[Thr 5068] done

[Thr 5068] stopAllThreads: stop Thread IOThread_2 ...[Thr 5068] done

[Thr 5068] stopAllThreads: stop Thread IOThread_3 ...[Thr 5068] done

[Thr 5068] stopAllThreads: stop Thread ADM-thread ...[Thr 5068] stopAllThreads: stop ADM-thread not implemented. Hard kill

[Thr 5068] ***LOG GEZ=> Server shutdown (normal shutdown) [encllog.cpp  501]

[Thr 5068] Enqueue server: normal shutdown

000)

[Thr 3088] EnqLockTableMapToLocalContext: enque/use_pfclock2 = FALSE

[Thr 3088] Mon Dec 22 12:03:19 2014

[Thr 3088] ***LOG GEZ=> Server start [encllog.cpp  501]

[Thr 3088] Enqueue server start with instance number 01

Any idea what could solve this pronblem?

Kind regards.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

10 Answers

  • Dec 29, 2014 at 12:44 AM

    The possible causes:

    You did an in-place upgrade of the OS and this is not supported. As far as I know you should be doing a system copy to move to Windows 2008 R2.

    1476239 - SAP system migration to Windows 2008/2008 R2

    1383873 - Windows Server 2008 R2 Support

    Check whether the runtime Java (JRE) used by the system is outdated and if yes update that and see if the J2EE stack comes up.

    Lastly I would check if the present kernel is compatible with Windows 2008 R2 and also if all the kernel files are present at D:\usr\sap\SP3\SCS01\exe and the profile directory \\spdev04\sapmnt\SP3\SYS\profile is accessible. You can try to trigger the sapcpe manually and see the error.

    Cheers

    RB

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 23, 2014 at 10:21 PM

    Have you tried restarting the server? Issues with enqueue are most likely due to the main memory.

    Check the Windows Event Viewer logs.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member S Sriram

      which log do you need? I can't find a log file dev_w0 or dev_disp

      ---------------------------------------------------

      trc file: "sapstartsrv.log", trc level: 0, release: "720"

      ---------------------------------------------------

      pid        1760

      [Thr 1876] Sun Dec 28 13:30:38 2014

      SAP HA Trace: SAP Microsoft Cluster library '720, patch 522, changelist 1465636' initialized

      CCMS agent initialization for instance type SCS: return code 0.

      CCMS agent start: return code 0.

      Initializing SAPControl Webservice

      Starting AutoRestart thread

      AutoRestart thread started, version check is enabled

      SapSSLInit failed => https support disabled

      Starting WebService Named Pipe thread

      Starting WebService thread

      Webservice named pipe thread started, listening on port \\.\pipe\sapcontrol_01

      Webservice thread started, listening on port 50113

      SPDEV04\sp3adm is starting SAP System at 2014/12/28 13:31:31

      SAP HA Trace: FindClusterResource: OpenCluster failed: 1060 [sapwinha.cpp, line 214]

      SAP HA Trace: SAP_HA_FindSAPInstance returns: SAP_HA_FAIL [sapwinha.cpp, line 936]

      SPDEV04\sp3adm is stopping SAP System at 2014/12/28 13:31:57

      SAP HA Trace: FindClusterResource: OpenCluster failed: 1060 [sapwinha.cpp, line 214]

      SAP HA Trace: SAP_HA_FindSAPInstance returns: SAP_HA_FAIL [sapwinha.cpp, line 936]

  • Dec 24, 2014 at 05:40 AM

    Hi Peter

    1.  Could you share the log dev_w0, dev_disp

    2. Kernel 720 level?

    BR

    SS

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 26, 2014 at 09:45 AM

    Hello Peter,

    Have you cleaned your ipc once with that command?

    cleanipc SN remove

    Also have a look at that topic:

    Regards,

    Serhat

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 26, 2014 at 03:08 PM

    Hi Peter,

    check vcredist_x64.msi is installed , if not  you should install, it contains in sapkernel.

    Regards,

    Umit Toptas

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I installed vcredist_x64.exe - but the server does still not starting - error message is the same... any other idea?

  • avatar image
    Former Member
    Dec 28, 2014 at 01:09 PM

    Hi Peter,

    Could you share dev_w0 log file from the location <Drive>:\usr\sap\<Sys-ID>\DVEBMGS<Sys-Nr>\Work

    Addition to it share the trans.log file as well from the command output of R3trans -d

    Regards,

    Gaurav

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      ---------------------------------------------------

      trc file: "dev_ms", trc level: 1, release: "720"

      ---------------------------------------------------

      [Thr 3668] Sun Dec 28 13:31:32 2014

      [Thr 3668] ms/http_max_clients = 500 -> 500

      [Thr 3668] MsSSetTrcLog: trc logging active, max size = 52428800 bytes

      systemid   562 (PC with Windows NT)

      relno      7200

      patchlevel 0

      patchno    441

      intno      20020600

      make       multithreaded, Unicode, 64 bit, optimized

      pid        3656

      [Thr 3668] ***LOG Q01=> MsSInit, MSStart (Msg Server 1 3656) [msxxserv.c   2288]

      [Thr 3668] Sun Dec 28 13:31:34 2014

      [Thr 3668] load acl file = D:\usr\sap\SP3\SYS\global\ms_acl_info.DAT

      [Thr 3668] MsGetOwnIpAddr: my host addresses are :

      [Thr 3668]   1 : [192.168.1.24] spdev04 (HOSTNAME)

      [Thr 3668]   2 : [127.0.0.1] spdev04 (LOCALHOST)

      [Thr 3668]   3 : [192.168.99.10] spdev04.sap.com (NILIST)

      [Thr 3668] MsHttpInit: full qualified hostname = spdev04

      [Thr 3668] HTTP logging is switch off

      [Thr 3668] set HTTP state to LISTEN

      [Thr 3668] *** HTTP port 8101 state LISTEN ***

      [Thr 3668] *** I listen to internal port 3901 (3901) ***

      [Thr 3668] *** HTTP port 8101 state LISTEN ***

      [Thr 3668] CUSTOMER KEY: >C1379120511<

      [Thr 3668] build version=720.2013.07.11

      [Thr 3976] Sun Dec 28 13:31:57 2014

      [Thr 3976] MsSExit: received SIGINT (2)

      [Thr 3976] set HTTP state to CLOSED

      [Thr 3976] *** HTTP port 8101 state CLOSED ***

      [Thr 3976] ***LOG Q02=> MsSHalt, MSStop (Msg Server 3656) [msxxserv.c   7712]

      ---------------------------------------------------

      trc file: "dev_rd", trc level: 1, release: "720"

      ---------------------------------------------------

      Sun Dec 28 13:31:32 2014

      ***LOG S00=> GwInitReader, gateway started ( 3984) [gwxxrd.c     1759]

      systemid   562 (PC with Windows NT)

      relno      7200

      patchlevel 0

      patchno    442

      intno      20020600

      make       multithreaded, Unicode, 64 bit, optimized

      pid        3984

      gateway runs with dp version 139000(ext=120000) (@(#) DPLIB-INT-VERSION-139000-UC)

      gateway (version=720.2013.07.12)

      gw/reg_no_conn_info = 1

      Sun Dec 28 13:31:33 2014

      gw/local_addr : 0.0.0.0

      gw/reg_no_conn_info = 1

      * SWITCH TRC-RESOLUTION from 1 TO 1

      switch off alert monitoring

      Bind service 3301 (socket) to port 3301

      GwIRegInitRegInfo: reg_info file D:\usr\sap\SP3\SCS01\data\reginfo.DAT not found

      GwPrintMyHostAddr: my host addresses are :

        1 : [192.168.1.24] spdev04.eminet.local (HOSTNAME)

        2 : [127.0.0.1] spdev04 (LOCALHOST)

        3 : [192.168.99.10] spdev04.sap.com (NILIST)

      Full qualified hostname = spdev04.eminet.local

      GwDpInit: not attached to gw_adm

      Sun Dec 28 13:31:57 2014

      GwISigint: received SIGINT (2), start shutdown phase

      ***LOG S30=> GwStopGateway, gateway stopped () [gwxxrd.c     13121]

      SAP-R/3-Startup Program

      Starting at 2014/12/28 13:31:31

      Startup Profile: "\\spdev04\sapmnt\SP3\SYS\profile\SP3_SCS01_spdev04"

      Starting Programs

      (3484) Execute: D:\usr\sap\SP3\SYS\exe\uc\NTAMD64\sapcpe.EXE pf=\\spdev04\sapmnt\SP3\SYS\profile\SP3_SCS01_spdev04 list:D:\usr\sap\SP3\SYS\exe\uc\NTAMD64/scs.lst

      (3460) Execute: D:\usr\sap\SP3\SYS\exe\uc\NTAMD64\sapcpe.EXE pf=\\spdev04\sapmnt\SP3\SYS\profile\SP3_SCS01_spdev04 list:D:\usr\sap\SP3\SYS\exe\uc\NTAMD64/sapcrypto.lst

      (3656) CreateProcess: D:\usr\sap\SP3\SCS01\exe\msg_server.EXE pf=\\spdev04\sapmnt\SP3\SYS\profile\SP3_SCS01_spdev04

      (3664) CreateProcess: D:\usr\sap\SP3\SCS01\exe\enserver.EXE pf=\\spdev04\sapmnt\SP3\SYS\profile\SP3_SCS01_spdev04

      (3984) CreateProcess: D:\usr\sap\SP3\SCS01\exe\gwrd.EXE pf=\\spdev04\sapmnt\SP3\SYS\profile\SP3_SCS01_spdev04 -no_abap

      Process 3664 died unexpectedly, restarting process

      (1448) Restart CreateProcess: D:\usr\sap\SP3\SCS01\exe\enserver.EXE pf=\\spdev04\sapmnt\SP3\SYS\profile\SP3_SCS01_spdev04

      Process 1448 died unexpectedly, restarting process

      (3864) Restart CreateProcess: D:\usr\sap\SP3\SCS01\exe\enserver.EXE pf=\\spdev04\sapmnt\SP3\SYS\profile\SP3_SCS01_spdev04

      Process 3864 died unexpectedly, restarting process

      (3936) Restart CreateProcess: D:\usr\sap\SP3\SCS01\exe\enserver.EXE pf=\\spdev04\sapmnt\SP3\SYS\profile\SP3_SCS01_spdev04

      Process 3936 died unexpectedly, restarting process

      (3568) Restart CreateProcess: D:\usr\sap\SP3\SCS01\exe\enserver.EXE pf=\\spdev04\sapmnt\SP3\SYS\profile\SP3_SCS01_spdev04

      Process 3568 died unexpectedly, final process restart.

      Process will not be restated in the future because of frequent failure.

      (3644) Restart CreateProcess: D:\usr\sap\SP3\SCS01\exe\enserver.EXE pf=\\spdev04\sapmnt\SP3\SYS\profile\SP3_SCS01_spdev04

      (1760) Parent Shutdown at 2014/12/28 13:31:57

      (1760) kill(SIGINT 3644) failed.

      Send Signal SIGKILL to Process 3644

      ---------------------------------------------------

      trc file: "sapstartsrv.log", trc level: 0, release: "720"

      ---------------------------------------------------

      pid        1760

      [Thr 1876] Sun Dec 28 13:30:38 2014

      SAP HA Trace: SAP Microsoft Cluster library '720, patch 522, changelist 1465636' initialized

      CCMS agent initialization for instance type SCS: return code 0.

      CCMS agent start: return code 0.

      Initializing SAPControl Webservice

      Starting AutoRestart thread

      AutoRestart thread started, version check is enabled

      SapSSLInit failed => https support disabled

      Starting WebService Named Pipe thread

      Starting WebService thread

      Webservice named pipe thread started, listening on port \\.\pipe\sapcontrol_01

      Webservice thread started, listening on port 50113

      SPDEV04\sp3adm is starting SAP System at 2014/12/28 13:31:31

      SAP HA Trace: FindClusterResource: OpenCluster failed: 1060 [sapwinha.cpp, line 214]

      SAP HA Trace: SAP_HA_FindSAPInstance returns: SAP_HA_FAIL [sapwinha.cpp, line 936]

      SPDEV04\sp3adm is stopping SAP System at 2014/12/28 13:31:57

      SAP HA Trace: FindClusterResource: OpenCluster failed: 1060 [sapwinha.cpp, line 214]

      SAP HA Trace: SAP_HA_FindSAPInstance returns: SAP_HA_FAIL [sapwinha.cpp, line 936]

      stderr3

      Server initialisation failed!

        Reason: "generic enqueue error detected at enio.cpp:203 Errorinfo: "Cannot resolve service <sapdp01>""

  • Dec 28, 2014 at 01:27 PM

    Check the latest logs present in the D:\usr\sap\SP3\SCS01\work directory.

    Have you checked event viewer logs for details?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 28, 2014 at 03:21 PM

    Hi Peter,

    During OS upgrade,have you performed any kernel patch up dations or any host name modifications for the domain registrations ? Please confirm.

    Regards,

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      no just the os upgrade - the sap system and the hostname is still the same.

      the os upgrade is the first step to upgrade the sap system to sap nw 7.4

  • avatar image
    Former Member
    Dec 28, 2014 at 10:58 PM

    Hello Peter,

    Did you maintain the services file in C:\WINDOWS\system32\drivers\etc ?

    sapdp01         3201/tcp

    sapgw01        3301/tcp

    sapms<SID> 3601/tcp

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Also, please run the command " netstat -p TCP " and check if the SAP ports are already in use by another process (3601, 3201, 3301 [assuming the sys# is 01])


      Thanks

  • avatar image
    Former Member
    Dec 29, 2014 at 03:10 AM

    Adding to above suggestion make sure you have secdata ( Java) folder available.

    kindly copy paste /usr/sap from old server to new.

    Add comment
    10|10000 characters needed characters exceeded