Skip to Content

Errors in Eclipse - while installing new software.

Hi,

I get following error while trying to install new software. I tried both Kepeler Service Release 2 and Luna versions and always get similar errors. Any idea what is missing?

Operation details

  Cannot complete the install because one or more required items could not be found.

    Software currently installed: ABAP Development Tools for SAP HANA (Developer Edition) 2.36.1 (com.sap.adt.tools.hana.devedition.feature.group 2.36.1)

    Missing requirement: ABAP Development Tools Foundation 2.36.2 (com.sap.adt.tools.feature.group 2.36.2) requires 'org.eclipse.mylyn.context_feature.feature.group [3.9.0,4.0.0)' but it could not be found

    Cannot satisfy dependency:

      From: ABAP Development Tools for SAP HANA (Developer Edition) 2.36.1 (com.sap.adt.tools.hana.devedition.feature.group 2.36.1)

      To: com.sap.adt.tools.hana.feature.group [2.36.1]

    Cannot satisfy dependency:

      From: ABAP Development Tools for SAP HANA 2.36.1 (com.sap.adt.tools.hana.feature.group 2.36.1)

      To: com.sap.adt.tools.feature.group 1.5.0

Thanks

Vj

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Dec 23, 2014 at 10:39 AM

    It asks for the version of ABAP Development Tools 2.36.2. But you have installed version 2.36.1.

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 29, 2014 at 07:49 AM

    While installing new features, Eclipse tries to retrieve required features automatically in the background. If this is not possible, you get an error message about missing requirements. In your case the "Mylyn Task-Focused Interface" (org.eclipse.mylyn.context_feature.feature.group) is missing. It can be downloaded automatically from http://download.eclipse.org/releases/luna (or .../kepler). Therefor this update site needs to be configured and enabled in your Eclipse installation.

    Regards, Felix

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 23, 2014 at 11:35 AM

    Hi Vijayendra,

    Please refer this blog post :

    Step-by-step Guide to setup ABAP on HANA with Eclipse

    I also faced so many issues while installing Eclipse but using above blog I was able to install Eclipse successfully.

    Hope it will help you too.

    Regards,

    Sneha

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 02, 2015 at 12:51 PM

    Some of your plug-in seems to be not up-to-dated; and other plug-in requires newer version of another ones.

    My advice to you:

    You need dowload eclipse once more.

    and install software from SAP Development Tools for Eclipse

    via eclipse: Help -> Install New Software

    in filed work with enter: https://tools.hana.ondemand.com/kepler

    (or luna) as you wish


    It is guarantee that you will have up-to-dated plugins.

    It will save your time if you will try to check version if every plug-in.

    also you need to install graphiti plug ins

    org.eclipse.graphiti

    and you need to change Java Version in eclipse via:

    window -> Preferences -> Java -> Compliler -> Compiler  compliance level -> should be 1.6

    Add comment
    10|10000 characters needed characters exceeded

    • Thanks Oleg. All seems to be working fine with Kepler version. I am still not able to install the plugins for Luna version. Always get some error. So i have given up and for time being prefer to work with Kepler.