Skip to Content

Currency display problem

Hi Frds,

My amount is  15,000,000.

But displaying as 15.000,000.

Screen attached Pls help me out.

Kabil

amount.jpg (6.5 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

8 Answers

  • avatar image
    Former Member
    Dec 23, 2014 at 07:34 AM

    Hi Kabil,

    Check your SAP settings. System -> User profile -> Own data -> Defaults

    What format is maintained there for decimal notation?

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 23, 2014 at 07:34 AM

    Hi,

    Go to system->user profile -> own data->defaults->decimal notation.

    Change it as required and then log off and log in.

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 23, 2014 at 07:36 AM

    Hi,

    Check the User setting in SU01 T-Code and change the Default Tab Information with respect to your requirement.

    Regards.

    Praveer.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 23, 2014 at 07:36 AM

    Hi,

    This could be because of default user profile settings wherein the Decimal notation would be such which has commas in place of decimals and vice versa.

    Regards,

    Aashika

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 23, 2014 at 07:40 AM

    Dear Frds,

    My user settings also in correct format only as all you suggested.


    SU01.jpg (29.9 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member kabil G

      Well, just for a check, you have mentioned the currency fields in smartform for the displayed fields right?

      According to me, this should be user settings issue only.

  • Dec 23, 2014 at 07:51 AM

    Hi,

    how you have declare the currency field in you Smart Forms.

    Since you are displaying the Information, so while displaying you can use the CHAR field variable also, you will the same format what has been coming in amount. 😉

    Regards.

    Praveer.

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 23, 2014 at 09:29 AM

    Hai Kabil,

    Can you check your SPRO settings for Country Global Parameters using the transactions OY01. There you will be able to see the currency format for IN. Please change this to your format. Once you had done, this please check and confirm whether your requirements met or not.

    Regards,

    Abijith

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member kabil G

      Hi Kabil,

      In Smartforms you declare a variable into Global Data

      V_NETWR  TYPE  NETWR

      Create a New Program Lines before your Text for Billing Value

      In Input Parametrs you put your file name where found billing amount

      In Output Parametrs you put v_netwr

      Into Statement panel you write

      CLEAR:V_NETWR.

      V_NETWR = <input parameters>-NETWR.



      Now you input into your text


      &V_NETWR(RK)&

      or

      &V_NETWR(<10.2)&

      I think it's solve your problem.

      NB. for RK see the below link

      Output Options for Field Contents - SAP Smart Forms (BC-SRV-SCR) - SAP Library

  • Dec 30, 2014 at 10:59 AM

    Dear All,

    Solved Myself Thanks closing these thread

    KABIL

    Add comment
    10|10000 characters needed characters exceeded