Skip to Content
avatar image
Former Member

IDM provisioning task not activated

Hello,

I'm having an issue getting the CORE/Provisioning task to be executed following the assignment of a privilege.

I've done a number of tests with other tasks (modifying users, creating users) that have been successful. But, using the 'assign' task in the Web Enabled Folder, the CORE/Provisioning task fails to execute.

I also tried creating a new role, adding the required privileges and assigning this to a test user. The log showed that provisioning did work, but no privileges were assigned.

In the monitoring tab, the provisioning audit shows the 38/Assign task as having a provisioning status of 'OK', but the related CORE/Provisioning task does not get executed.

How can I trouble shoot this? Where should I look first?

I'm currently on IDM 7.2 SP9. While on SP8 provisioning did work.

Could there be an issues with the database?

Appreciate the help. Happy holidays!

Paul

assign-ok.jpg (32.3 kB)
modify-ok.jpg (12.1 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Jan 09, 2015 at 12:50 PM

    Does the privilege you assign have a master privilege, or a repository that has a master privilege? And if so, is that master privilege succesfully assigned to the user? You should be able to see the state using

    SELECT * FROM idmv_link_ext where mcThisMSKEYVALUE = '<USER_MSKEYYVALUE>' order by mcUniqueId


    I don't remember all the column names, and SP9 might have introduced a new "masterprivilegeassignmentstate" or similar column as well, but mcThisMSKEYVALUE, mcOtherMSKEYVALUE, mcLinkState,mcExecState, mcAssignedDirect, mcAssignedInheritCount should give a basic idea of the assignment state.





    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Per,

      Yes, the privilege I assigned does have a master privilege associated with it. See below.

      The Tasks tab for this privilege shows the following:

      And here it shows that master privilege assigned to the user.

      I did execute this query using the user logonid as well, and it came back with mcExecState = 1.

      I still suspect this is related to a issue with creating a company address, for which I get the following errors in the provisioning queue.

  • Dec 23, 2014 at 02:22 PM

    Hi Paul,

                did you import the SP9 framework when you updated to SP9 as this also delivers updates to scripts used by the framework.

    I would also check the provisioning queue at db level for the tasks and cross check the audit tables for these tasks to check for errors.

    Regards,

    Chris

    SAP AGS

    Add comment
    10|10000 characters needed characters exceeded

    • Hi - I would try restarting the db and if that does not help try creating a new dispatcher and assign the jobs to this new dispatcher and see if the behaviour changes - try and rule out if it is an issue specific to the dispatcher. I also assume the runtime is on SP9 and this is shown in the dispatcher overview.

      Thanks,

      Chris

  • Jan 09, 2015 at 01:09 PM

    Hi Paul,

    Let's investigate the case step by step, because the reasons can be many.

    First question: Did the privilege you are trying to assign to the person is assigned to it with OK status in IDM? If not what is the status? Or you don't see it at all?

    After you answer this question, there might be the others to follow.

    Best regards,

    Ivan

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello, you might want to review a recent article that I wrote regarding this scenario.  This walks you through repository and priv config.  Hope this helps.

      Scott