Skip to Content

JCO TimeOut property

Hello,

I am trying to set dynamically the timeout of JCo session via Start session or directly through JCO Interface using Configure Object or through Links but it does not seems to be taking effect.

It timeout after 10 mins which is the default value irrespective of timeout value I provide .

Anybody faced this issue ? Any pointers in this regards if there is any more setting needed in NW or else where

SAP MII 14.0 Sp4 Patch 2

NW 7.3

Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Dec 23, 2014 at 06:13 AM

    Hi Nikhil,

    JCO timeout property times out idle JCo sessions only. If you are testing connections which are in use, they will not timeout as per the specified property.

    you can specify the JVM parameter -D jco.session_timeout property in config tool to increase timeout.

    Regards,

    Anushree

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 23, 2014 at 06:18 AM

    Hi Nikhil,

    Please check following link:

    SAP Library - JCO Client Service

    You may want to check these settings as well:

    Configure the JCO Client Service (SAP Library - JCO Client Service)

    Regards,

    Swaroop

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 23, 2014 at 06:42 AM

    Hi Nikhil,

    Also to add,please check below section from help doc.

    Timeouts

    ConnectionTimeout

    Integer

    Defines the number of seconds after which to disconnect. If you enter a value greater than ten minutes, which is the default value, the connection times out at ten minutes.

    So, you will have to modify this default setting to extend your session beyond 10 minutes.

    Hope this helps.

    Regards,

    Swaroop

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 23, 2014 at 07:19 AM

    Hello,

    @Anushree -  I am not sure if this property is for idle pool only because while making a JCO call means active session , it time out after 10 min set as default value irrespective of value as i mentioned.

    Don't you think it time out during active session because call is in progress?

    If this property is for idle connection then is there any way to set time out for active session?

    Thanks

    @Swaroop - I am aware of this property and this property not taking effect as I need to define less than 10 mins which I am not sure if only works for idle session as Anushree pointed

    Thanks.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Nikhil,

      If you create a connection but forget to close it after you have made a function call, this property comes in handy.

      Please see my last reply for the property you can set in order to timeout an active session.

      Regards,

      Anushree