Skip to Content

EMIGALL: The file is not open

Hi everyone.

Im creating new migration project and im facing the following issue: when I try to convert the input file, I always get ABAP short dump saying: "When accessing the file "c:\test\test.tst", the system recognized that the file is not open. Therefore, the file cannot be accessed". The error is in the ABAP program SAPLEMIG_FILE.

I have only one migration object in the project. I have coppied the migration object from SAP reference company, as usual. I created a text file which consists of &INFO line, one set of data and its concluded with &ENDE command. The file is tab delimited text file.

What I tried so far:

- running the conversion through transaction EMIGALL, choosing migration object, then "Data import" from the "Migration object" menu, and then "Convert migration file" from "Utilities" menu

- running the program REMIG_FILE_TRANSFORM from SE38 transaction

- converting the file which is uploaded from the workstation (option: Input is local file)

- converting the file which was put on server (option: Input is text file)

- changing the user rights of the server folder (both input and output folders)

- making input and output folder the same, distinguishing the file extensions

- changing the content of the file (although the file should be ok, since Ive used the structure more than once)

- I get the same error when I click on "Create file" icon on "Data import" screen on the EMIGALL transaction

When I check the server folder, SAP actually created the needed file (lets call it test.tst in this example), but its size is 0 and it never contains anything.

Did anyone had a situation like this or has some ideas on solving this issue?

Thanks!

Marko

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Jan 12, 2015 at 10:55 PM

    Hi all.

    In case anyone else gets this error: there is a "work" folder (for example: /usr/sap/AAA/DVEBMGS00/work, where AAA is your instance ID) which does not give this error and lets you create and import files into. Giving the same rights to another folder on the drive, however, is not solving the problem. Nevertheless, the "work" folder can be used for the data import.

    Marko

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 26, 2015 at 11:14 PM

    Hi Marko,

    Did you check the file permissions for the user name that shows up on the file that you created using "Create file" icon (test.tst) - it would be sapadm/sysadm or whatever the user id that shows up when creating file through EMIGALL/SAP.

    You need to ensure that default user-id (e.g. "sapadm"/ "sysadm") has read/write/execute permissions to your folder/directory. When using the  "Convert migration file" step from the "Utilities" menu or "running the program REMIG_FILE_TRANSFORM from SE38 transaction" - either way, the output file gets written by default SAP admin user-id.

    Hope this helps.

    Ashvinder


    Add comment
    10|10000 characters needed characters exceeded

    • Hi Ashvinder.

      Thanks for replying. Yes, I checked user rights on both SAP system and server operating system and SAP admin had r/w rights. Finaly, it helped when I assigned a new folder in transaction AL11 and used that folder in the EMIGALL.

      Marko