Skip to Content

ITS 6.20 stopped working

Hi,

We had our 6.20 patch 45 running just fine itsmobile apps. Apparently, without any change in ITS configuration, ITS stopped working with error

Interpreter Failed

The Internet Transaction Server failed to generate the response for current request.

Please contact the system administrator.

Internal error code: 0x2101

Even itsmobile test services fail now (itsmobile00, itsmobile01, ...). After checking diagnostics.log we found that for some reason ITS is now looking for templates in the wrong location.

For example for service itsmobile01 in stead of looking for template "sapmimob1_500.html" at location

"C:\Program Files\SAP\ITS\6.20\IT1\templates\itsmobile01\99"

ITS is looking for (found in diagnostics.log) 

"Error, template: `C:\Program Files\SAP\ITS\6.20\IT1\templates\itsmobile\99\sapmimob1_500_en.html', resource: `', rc=0x2101"


What happened and how to correct this?


ITS acts like there is no folder "C:\Program Files\SAP\ITS\6.20\IT1\templates\itsmobile01\99" and there is with template sapmimob1_500.html.

Additionally ITS is looking for sapmimob1_500_en.html instead of sapmimob1_500.html, why?

Best regards,

Sasha

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Dec 23, 2014 at 06:49 AM

    Hello Sasa,

    Have you published relevant services?
    Have you tried note 508172?

    Best regards,

    Yuki

    Message was edited by: Oisin ONidh ITS SCN Moderator Add note links

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 22, 2014 at 09:04 PM

    Hello Sasha,

    Was any changes made on the R/3 side? that the instance 'IT1' connects too?

    Regards,

    Oisin

    Add comment
    10|10000 characters needed characters exceeded