Skip to Content
avatar image
Former Member

Error: IDOC_ERROR_METADATA_UNAVAILABLE

Hi Everybody,

I need experts advice for receiving  custom IDOCS from ECC4.6 to PI 7.4 single stack Java.

Issue: we have one scenario, where my sender system is ECC 4.6 is sending custom IDOC to PI 7.4 but unfortunately PI is unable to receive the same and it got stuck in sender ECC (It is an legacy UNICODE system) SM58 with error "IDOC_ERROR_METADATA_UNAVAILABLE". where as PI able to receive standard IDOC from the same system.

Even when we checked in NWA logs  & errors showing the same  error like " IDOC_ERROR_METADATA_UNAVAILABLE".

We checked have reimported the meta data and refreshed the cache even though getting the same error and also we have implemented notes 1767710 ,1473183 ,1529038 & 1405466 but there is no use.

Am very much thankful to every one who can contribute to resolve the same.

Regards,

Chandu :-)

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Dec 22, 2014 at 01:59 PM


    Hello,

    Check IDOC sements are released properly in ECC

    also if extension exist for IDOC, check that extension was mentioned/linked correctly with basic type.

    Reagrds,Prasanth

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Chandu,

      what is the IDOC type that you are Using.

      Did you tried to register metadata manually in PO - IDOC metadata monitor?

      plz also check IDOC extension is

      linked with basic type (Display IDOC types--> extension Attributes)?

  • avatar image
    Former Member
    Dec 22, 2014 at 02:15 PM

    Hi,

    Sometimes this can be related to authorisation issue. Please check.

    Message was edited by: Leela Morampudi

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      If issue not solved. Try

      1. get IDO Cnumber from message failed in SM58. then delete entry in sm58 and try to resend IDOC from we19. (if IDOC status is Green)

      2. Some time this issue may occur in consistent SLD entries. like

      the Business system may not have the software component related to your IDOC configuration.

      So check the sender tab of business system in ID. will it has your IDOC is in outbound interafces list.

      if not check SLD --> Busienss system-->installed software

      Reagrds,

      Prasanth


  • avatar image
    Former Member
    Dec 25, 2014 at 09:51 AM

    Hi,

    At ECC side idoc would probably stuck in tRFC in your case.

    Try to resend idoc from WE19.

    But AFAIK it could be an authorization issue.

    Regards,

    Dipen.

    Add comment
    10|10000 characters needed characters exceeded