Skip to Content

Single record not getting display in SE16

Hi All,

I am facing a weird issue here.

I go to SE16, put table name.

I execute table without any input in selection screen.

I get all records from table.

But if I put above highlighted VBELN on selection screen, I don't get the result.

I tried padding 0, * , nothing works.

This issue is coming with few records only, as if I chose some other single record, it works.

Please help, what could be the issue?

1.png (6.8 kB)
1.png (11.8 kB)
1.png (5.0 kB)
1.png (20.6 kB)
1.png (2.0 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

10 Answers

  • Best Answer
    avatar image
    Former Member
    Dec 22, 2014 at 05:45 PM

    Hi Neminath

    I have faced this issue earlier.

    The problem was with "CONVERSION EXIT".

    Although you say that you have uploaded it with leading zeroes as you can see in the table entries : But this might not be the actual case. Issue  is : during uploading those entries without conversion exit or whichever way you uploaded but was not same for the one which you are facing problem.


    Since mine was a quality system , I deleted all the entries and uploaded it again.(worked for me).

    But in your case since it is production system.

    I suggest you to find those entries in production .Upload again(Using Conversion routine) in development

    system and release it to production through CUSTOMIZING TR.

    Then delete the duplicate entries in production(if any).

    That is the only possible solution.

    Thanks

    Kishan Shah

    Add comment
    10|10000 characters needed characters exceeded

    • How many records? If you're talking a few thousand - that's trivial. With a few million, use OPEN CURSOR to process the records (e.g.) 10'000 at a time.

      It should be a one off fix - but it's the only way to get all the failures. (Other than reloading which is going to take you a long time as well).

      What you must do is ensure whatever process you're using to load this data doesn't allow records without leading zeros. The original loading program should have put them in - relying on the users to get the data right is not wise.

  • Dec 22, 2014 at 09:38 AM

    Hi,

    Try to Use SE14 T-Code and adjust the table once.

    May be some confliction is there.

    Regards.

    Praveer.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 22, 2014 at 07:35 AM

    Hi Neminath,

    Strange issue!!!

    Is it working fine in SE11 and SE16N? Did you give a try?

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 22, 2014 at 07:38 AM

    Hi,

    Hope you are using the same Data element for VBELN, which is provided by the SAP.

    Regards.

    Praveer.

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 22, 2014 at 07:41 AM

    It seems you are finding an entry in some Z table. It might be possible that you have uploaded some data into Z table without using Conversion Exit. So, some data may not have leading zeros and some may have leading zeros. Kindly check the same.

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 22, 2014 at 08:50 AM

    When i tried using wild char * its working

    But wild card needs to be put on both side. This is again a weird thing.

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 23, 2014 at 06:20 AM

    This message was moderated.


    UserPara.jpg (38.2 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • Dec 23, 2014 at 07:00 AM

    This message was moderated.

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 23, 2014 at 07:20 AM

    This message was moderated.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 23, 2014 at 09:57 AM

    Hi Neminath

    This post is unnecessarily getting extended with the same set of solutions.

    Request you to please close the thread.

    Add comment
    10|10000 characters needed characters exceeded