Skip to Content

Incorrect Log on parameters in Crystal Reports after publishing in CMC

Steps

Log on to Remote desktop

Open Crystal Reports IDE

Open Report and run, it works fine.

Now Log on to CMC

Publish the Crystal Report

Right click on report and choose Default Settings

Click on Database Config

Displays the user name

Close settings

Right click on report and choose Run Now

Report runs

Click on report and choose History

Instance status shows "Failed"

Can some body help please?

Another scenario I went to Database configuration retyped User Name and Password and save in Default Settings of report. Still the result is same but the message is Database Vendor Code 18456.

Can some body help please?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Dec 30, 2014 at 05:44 AM

    Hi,

    Are you able to view the report successfully in CMC?

    Looking at the error message, I am assuming that you are creating the report on top off MS SQL Server 2008 R2. Is that the case? Just to inform you that MS SQL Server 2008 R2 with native drivers on Windows is not supported as of yet.

    Also, does your Crystal report contain any sub-report or parameters (specifically numbers or date)? If yes, you can try removing each one-by-one and drill down to what is causing the problem.

    Regards,

    Rahul

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 30, 2014 at 08:08 AM

    Hello,

    There are a lot of details still missing in your post.

    1. What is the BO version ?

    2. What is the database version ?

    3. Is the report based off an ODBC connection ? If yes, is the ODBC connection using SQL authentication or Win NT ?

    4. Do you have CR designer installed on the BO server itself ? If yes, are you able to refresh the CR report from CR designer installed on the server ?

    Regards,

    Kunal

    Add comment
    10|10000 characters needed characters exceeded