Skip to Content

Create Attachment showing in Dev client but unavailable in Quality client

Hi,

In Development Client, in Change Travel Expense Report, I can create Attachment and attach expense receipts scan copies. But when I try attaching the receipts in Quality client, the create Attachment option is not available.

I thought this will be authorization issue, but even when I use Super User authorization, it does not work.

Attaching the screen shots.

In Development Client

In Quality Client

Please suggest, what may be the reason.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

5 Answers

  • Best Answer
    Posted on Dec 11, 2014 at 01:36 PM

    Hi Nabin,

    Why don't you try debugging on T Code Trip and check the attachment screen.

    I suppose the Create Attachment is having Invisible status. Once you debug, you can check the status in SGOSCUST. If the status is 2, that will be the reason why the Create Attachment is Invisible for you.

    There are 3 status indicators in SGOSCUST table.

    0- Active

    1-Inactive

    2- Invisible.

    If you find the status in SGOSCUST table as 2, you got your.

    You need to take any abaper help to change the status to 0 and the try login again. Hope you can see and attach receipts in Create---> Attachment under T Code- TRIP.

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi,

      to properly do the configuration you do need authorization for SGOS; you can't configure it in a clean way otherwise. You should tell this the responsible person for your authorization concept so you are given the authorization. When maintaining the respective entries via SGOS, you'll be prompted for a workbench transport which can be used for transporting the changes (naturally).

      The only reasons I can think of why the setting are different on your system is, that somebody uncleanly manipulated the customizing table or has customized via SGOS and then threw away the transport (even uncleaner).

      Cheers, Lukas

  • Posted on Dec 11, 2014 at 03:24 PM

    Hi Nabin,

    Please refer to some OSS notes, where you can find the table differences between, Development client and Quality client.

    Then you can go to the T Code- SGOS and correct the status.

    I suppose, the config was not copied to your quality client.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 09, 2014 at 10:55 AM

    Hi Nabin,

    please note that it is fallacious to think you can rule out an authorization issue by assigning SAP_ALL/SAP_NEW.

    Check the user on QAS and check whether he has different authorization especially in Object S_BDS_DS than the user on DEV.

    Cheers, Lukas

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 11, 2014 at 01:39 PM

    Hi Vijay I tried this option, as u suggested. You are correct.

    I would like to know, if this is linked to any configuration since I found the status as 2 in Table SOGSCUST.

    Instead of changing the status from table, can you suggest the SPRO route?

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 11, 2014 at 03:49 PM

    Hi Nabin,

    The sap note: 1873544 shows that you need to execute Report-RSGOSCHECK. Once you execute this report, you can find the differences.

    Cheers.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.