Skip to Content

DI Server Ampersand (&) Error

Hi All,

I'm having an issue with the Ampersand (&) character in the DI Server call using DIServer.Interact

The following works perfectly:

<DoQuery>CardName from OCRD where CardCode = 'pamgong11'</DoQuery>

The following does not work:

<DoQuery>CardName from OCRD where CardCode = 'pamgong1&1'</DoQuery>

The error returned is the following:

<env:Reason>

<env:Text xml:lang="en">Invalid XML</env:Text>

</env:Reason>

<env:Detail>

<ErrorList>

<Error>System Id = 156847432, Line Number = 1, Column Number = 300, Description = Expected entity name for reference</Error>

</ErrorList>

How do I handle a DI Server call that contains the Ampersand (&) character?

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Dec 08, 2014 at 08:10 PM

    Hi Barend,

    Have you tried &amp; instead of the &? Haven't tested it though:

    <DoQuery>CardName from OCRD where CardCode = 'pamgong1&amp;1'</DoQuery>


    Best regards,

    Pedro Magueija


    View Pedro Magueija's profile on LinkedIn

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.