Skip to Content
author's profile photo Former Member
Former Member

SAP GW Subscription & notification : Error - internal source pos cx_static_check /iwbep/cx_mgw_base_exception

Hi All,

While trying to prove Gateway Subscriptions & Notifications, I am below error...

internal source pos cx_static_check /iwbep/cx_mgw_base_exception

I could able to create Subscription successfully, and I am getting this error @ send_notifications

TRY .

lo_notification_publisher->send_notifications(

is_notification_endpoint = ls_notification_endpoint ).

CATCH /iwbep/cx_mgw_tech_exception INTO lx_mgw_tech_exception.

help me to sort this,

Thanks

Rajesh

Untitled.png (108.3 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    Posted on Dec 08, 2014 at 08:26 AM

    Hi Rajesh,

    Check this reply for Invalid destination error.

    It would be better if you debug inside "lo_notification_publisher->send_notifications" method and check for the system alias, destination there and check the configuration of these.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 08, 2014 at 02:37 AM

    Hello Rajesh,

    Could you please check without Try and Catch ?

    Just call send_notifications method alone to send back End-Points.

    Regards,

    Ashwin

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 08, 2014 at 03:13 AM

    Rajesh, Error i see from the log is "CX_BGRFC_INVALID_DESTINATION". You might search the forum with that. I quickly found this.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 10, 2014 at 11:38 AM

    Hi All,

    Finally I am closing my post as Answered because I could able to hit my delivery address with notifications, but these notifications are showing with 500 error code at HUB... until unless I release or delete them manually they not going out....

    Here my delivery address is not external , I am using the same HUB box with different port.

    I would like to thank Eknash & Ashwin for support through(don't know how can I give points to equally 😊 )

    Thanks

    Rajesh

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.