Skip to Content
author's profile photo Former Member
Former Member

LSMW (batch input recording) to assign materials to

Hi everyone,

I have a problem with LSMW and need urgent help; The goal is to assign materials to characters through classes. We have list of materials, which must be assigned to the same class through LSMW;

We have created one class through transaction CL01:

Class type: 001

Class: class_mat

Afterwards we have created one character through transaction CT04:

Character: CLASS_MAT_ANALOGUE (name - analogue), that is assigned to class by default.

Than, manually we have assigned several materials to class (Class type: 001, Class: class_mat); Through this assignment character has been shown on screen, where we assigned character values from table MARA.

Then I have created first LSMW (batch input recording) for assigning all materials to one class (fields: MATNR, KLART, CLASS_01) and made assignment; We had no problems with this; But afterwards, we wanted to assign character values to materials, but with no result; LSMW is using transaction MM02 and fields are: MATNR, KLART, CLASS_01, MNAME_01. LSMW didn't end up with error, but it is not assigning values of characters to materials; Manually (MM02) everything is ok.

Can anyone help me to solve this problem? I would appreciate any kind of help; I have attached print screen of MM02, this is how second LSMW ends up, with no character values.

Thanks a lot in advance.

Regards,

Georgiana

MM02.jpg (199.2 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Dec 05, 2014 at 05:23 PM

    Did you try to run the batch input in foreground? did you get to this classification screen?

    Can you add a screenshot from a transaction of your batch input session which shows the dynpro fields with its values?

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Jürgen Lins

      Dear Jurgen,

      I dont't know how to thank you; I have changed my procedure as you have mentioned above and it's working; I was indicating value instead of character name; Thanks again for your help; Tomorrow I'll try several values for one material, hope it's gonna work; thanks alot again;

      Best regards,

      Georgiana

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.