Skip to Content
author's profile photo Former Member
Former Member

Sybase Central issue with SSL

Bonjour,

since I installed Java 1.8 on my system I endup with the following error message when trying to connect on a Sybase instance using SSL connexion :

JZ006: Caught IOException: javax.net.ssl.SSLException: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty

Code d'erreur=0
Etat SQL=JZ006 null
Code d'erreur=0
Etat SQL=null

Paramètres de connexion :
Utilisateur=sa
Mot de passe=*******
ENG=myaseinstance

I have been looking over the net and found information about Trust Store but nothing to help me fixing this unfortunate situation.

Anyone had the same issue?

Thanks

William

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Dec 04, 2014 at 05:50 PM

    It seems not related to my java installation. Once removed I still have the same issue.

    I can not connect using Sybase Central but I can connect through isql with no problem.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Ryan Hansen

      You are a KING Ryan!

      My connection works like a charm now!

      I think I owe you a beer man ;o)

      Thanks for your time and expertise Ryan, verry appreciated!

      EDIT

      If I can make a suggestion, if you have more than one ASE instance that is using SSL :

      %SYBASE_JRE6%\bin\keytool -import -alias ase_inst_1 -file ase_inst_1.crt -keystore trustedstore

      %SYBASE_JRE6%\bin\keytool -import -alias ase_inst_2 -file ase_inst_2.crt -keystore trustedstore

      %SYBASE_JRE6%\bin\keytool -import -alias ase_inst_1 -file ase_inst_1.crt

      %SYBASE_JRE6%\bin\keytool -import -alias ase_inst_2 -file ase_inst_2.crt

      P.S. I am not quite sure why you have to import each instance cert file twice, one with the -keystore option and the second without. If you do not, it doest work, but why!? Don't know!

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.