Skip to Content
author's profile photo Former Member
Former Member

Need to remove the Older work item in workflow

Hi Workflow Experts,

I have an issue in PO workflow. Assume PO number is 6000016025. There is a problem in removing older work item. Because when i check in SWI6 i see the recent work item created after PO indicator released but older work item is not being removed as below screen shots shown. Can anyone having ideas regarding this issue?. Many thanks in advance.


In this below 1st screenshot 3rd highlighted work item is been created recently after PO indicated released.

In below screenshot 1st highlighted older workitem is not being removed.

1852-II.JPG (90.7 kB)
1852-III.JPG (89.6 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Dec 03, 2014 at 01:51 AM

    That is not right. If the workflow is completed, then the individual work items inside the workflow, should be completed (or logically deleted) also.

    There is one possibility. The work item might be actually completed, but the log is displaying it wrong (I've seen something similar with other WF transactions). Get the work item number, and then check it with SWI1, and see if the status really is still "In process". You can also find the status in SWWWIHEAD table (header table for work items).

    Well, you are saying that you are removing old work items. What do you mean by remove?

    Regards,

    Karri

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Rick Bakker

      Hi Rick Bakker,

      Thanks for the response. So it seems there is only one temporary solution that older work item to be deleted. Can you pls guide me how can i delete that older work item which still shows as 'In Process'. Kindy guide me on this case. Many thanks in advance.

  • Posted on Dec 03, 2014 at 04:37 AM

    Hi Kavi

    For the step which is "In- Process" in the first workflow:

    1) Check the Technical WF log and the step history for that step - are there any errors or warnings listed there?

    2) Check ST22 - at the time of that step start date an time - do we have any error there?

    3) In the Technical WF Log - select the first node (the WF Header) an see if there is any info on the Step History of the main WF

    regards,

    Modak

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      What is the status of that "older work item". If it is cancelled (or logically deleted), then it will not be visible in the user's inbox.

      You can also check the user's inbox with transaction SWI5. If you cannot find the work item there, then you will know that the item is not visible for the user.

      Kind regards,

      Karri

  • Posted on Dec 02, 2014 at 02:04 PM

    Hi,

    You misunderstood the thing. Actually this screenshot all workitem are in completed status, that means executed successfully.

    From this log comparing time you will find the latest one. And user will easily understand that what happened to that workflow previously

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Anjan Paul,


      Thanks for your swift reply. My doubt is that In the log, you can see the old item is still “In Process” and the actual old work item is still sitting in user inbox waiting for further action. Isn’t the workflow suppose to delete the old work items if there is any change in PO? Many thanks in advance.

  • Posted on Dec 02, 2014 at 11:09 PM

    Hello,

    Yes, it is a bit strange. When a workflow is Completed normally all of the workitems are completed.

    You should look at the workflow log in SWI1 and see what happened and especiallyhow the workflow got completed.

    regards

    Rick Bakker

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Rick Bakker,

      Thanks for the valuable information. When i check in SWI1, i am not seeing workflow's for particular step is not completed. Below are the screen shots for your reference. As per below screenshots for the particular release, exection is been started and comes again with exection started statement often more than 5 times in technical log and still its not completed.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.