Skip to Content
avatar image
Former Member

Issues in installing Web IDE

Hi,

I am trying to install Web IDE using the following tutorial. http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/d010835c-b539-3210-6eb6-906c58d3c573?QuickLink=index&overridelayout=true&59575491491814

However I am facing these errors during installation.

!ENTRY org.eclipse.update.configurator 4 0 2014-12-01 09:43:55.902

!MESSAGE Could not install bundle plugins/org.eclipse.update.configurator_3.3.300.v20140518-1928.jar   A bundle is already installed with the name "org.eclipse.update.configurator" and version "3.3.300.v20140518-1928"

!ENTRY org.eclipse.update.configurator 4 0 2014-12-01 09:43:55.904

!MESSAGE Could not install bundle plugins/org.sat4j.core_2.3.5.v201308161310.jar   A bundle is already installed with the name "org.sat4j.core" and version "2.3.5.v201308161310"

!ENTRY org.eclipse.update.configurator 4 0 2014-12-01 09:43:55.906

!MESSAGE Could not install bundle plugins/org.sat4j.pb_2.3.5.v201404071733.jar   A bundle is already installed with the name "org.sat4j.pb" and version "2.3.5.v201404071733"

!ENTRY org.eclipse.equinox.p2.director 4 10053 2014-12-01 09:43:56.558

!MESSAGE Cannot complete the install because one or more required items could not be found.

!SUBENTRY 1 org.eclipse.equinox.p2.director 4 0 2014-12-01 09:43:56.558

!MESSAGE Software being installed: Feature 1.4.4 (com.sap.webide.orionplugin.feature.feature.group 1.4.4)

!SUBENTRY 1 org.eclipse.equinox.p2.director 4 0 2014-12-01 09:43:56.558

!MESSAGE Missing requirement: resource 1.22.9 (com.sap.ui5.resource 1.22.9) requires 'package javax.servlet 0.0.0' but it could not be found

!SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-12-01 09:43:56.558

!MESSAGE Cannot satisfy dependency:

!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-12-01 09:43:56.558

!MESSAGE From: SAPUI5 Runtime (Server-side Components) 1.22.9 (com.sap.ui5.runtime.feature.feature.group 1.22.9)

!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-12-01 09:43:56.558

!MESSAGE To: com.sap.ui5.resource [1.22.9]

!SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-12-01 09:43:56.558

!MESSAGE Cannot satisfy dependency:

!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-12-01 09:43:56.558

!MESSAGE From: Feature 1.4.4 (com.sap.webide.orionplugin.feature.feature.group 1.4.4)

!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-12-01 09:43:56.558

!MESSAGE To: com.sap.ui5.runtime.feature.feature.group [1.22.9]

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Best Answer
    avatar image
    Former Member
    Dec 05, 2014 at 07:31 PM

    I tried the same. But still getting these errors.

    !SUBENTRY 1 org.eclipse.equinox.p2.director 4 0 2014-12-05 11:26:41.725

    !MESSAGE Software being installed: Feature 1.4.4 (com.sap.webide.orionplugin.feature.feature.group 1.4.4)

    !SUBENTRY 1 org.eclipse.equinox.p2.director 4 0 2014-12-05 11:26:41.725

    !MESSAGE Missing requirement: com.sap.webide.orionplugin 1.4.4 requires 'bundle org.eclipse.equinox.http.registry 0.0.0' but it could not be found

    !SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2014-12-05 11:26:41.725

    !MESSAGE Cannot satisfy dependency:

    !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-12-05 11:26:41.725

    !MESSAGE From: Feature 1.4.4 (com.sap.webide.orionplugin.feature.feature.group 1.4.4)

    !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2014-12-05 11:26:41.725

    !MESSAGE To: com.sap.webide.orionplugin [1.4.4]

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 05, 2014 at 08:44 AM

    Hi, it's not easy to understand what happened from these logs. I suggest you to give a look to the following How-To-Guides and retry the installation:

    H2G Install SAP Web IDE locally for trial (Wind... | SCN

    and

    H2G Install SAP Web IDE locally for trial (Mac ... | SCN

    If you still have problems then, let me know.

    Regards,

    Simmaco

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 04, 2015 at 06:12 PM

    I have been following this for this link for installation:-

    http://scn.sap.com/community/developer-center/front-end/blog/2014/12/24/start-with-the-sap-web-ide-on-premise

    You've definitely downloaded the wrong director version. I realised I had download version 5.0 and for windows 64 bit and I had the same errors that you are having.

    I have just downloaded version 8 for windows 32 bit and the installation has completed.

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 26, 2015 at 09:31 PM

    did you get your issue resolved/ what was the solution. I have the same error

    c:\SAPWebIDE\director>director -repository jar:file:/c:/updatesite.zip!/ -instal

    lIU com.sap.webide.orionplugin.feature.feature.group -destination c:\SAPWebIDE\e

    clipse

    Installing com.sap.webide.orionplugin.feature.feature.group 1.4.4.

    Installation failed.

    Cannot complete the install because one or more required items could not be foun

    d.

    Software being installed: Feature 1.4.4 (com.sap.webide.orionplugin.feature.fea

    ture.group 1.4.4)

    Missing requirement: com.sap.webide.orionplugin 1.4.4 requires 'bundle org.ecli

    pse.equinox.http.registry 0.0.0' but it could not be found

    Cannot satisfy dependency:

      From: Feature 1.4.4 (com.sap.webide.orionplugin.feature.feature.group 1.4.4)

      To: com.sap.webide.orionplugin [1.4.4]

    Application failed, log file location: C:\SAPWebIDE\director\configuration\14274

    04925609.log

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 05, 2015 at 12:15 AM

    Hi Experts,

    I have the same problem.


    My Java Version:

    When I try to install:

    Log:

    !SESSION 2015-05-04 21:03:19.344 -----------------------------------------------

    eclipse.buildId=unknown

    java.version=1.7.0_79

    java.vendor=Oracle Corporation

    BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=pt_BR

    Framework arguments:  -repository jar:file:..//updatesite.zip!/ -installIU com.sap.webide.orionplugin.feature.feature.group -destination c:\SAPWebIDE\eclipse

    Command-line arguments:  -repository jar:file:..//updatesite.zip!/ -installIU com.sap.webide.orionplugin.feature.feature.group -destination c:\SAPWebIDE\eclipse

    !ENTRY org.eclipse.update.configurator 4 0 2015-05-04 21:03:20.600

    !MESSAGE Could not install bundle plugins/org.apache.ant_1.9.2.v201404171502/   A bundle is already installed with the name "org.apache.ant" and version "1.9.2.v201404171502"

    Can anybody help?

    Regards,

    Pina

    Add comment
    10|10000 characters needed characters exceeded

  • May 10, 2015 at 11:55 PM

    Thanks for this post, I had the same error in Mac, I downloaded x86 32bits version and works for me!

    Add comment
    10|10000 characters needed characters exceeded