Skip to Content

webi function 'connection(dp)' error.

Hi

We are in the process of migrating the reports and objects from XIR2 system to BO 4.0 SP7 Patch 4 system. For some Web I reports that we have migrated, we have used the function 'Connection(dp)'. We can see that this function returns a different data in XI R2 and BO 4.0 systems.

In XIR2 the function returns the following data

10;OracleOCI9;Oracle1097;VERSION=7;USER='USERNAME';PASSWORD=;DBTYPE=Relational;DATABASE=XXXX;238;VERSION=6;Name='CONNECTION NAME';Shared=4;LoginTimeout=600;Timeout=600;Pool Time=10;Array Fetch Size=250;Array Bind Size=32767;RecommendedLenTransfert=32000;Password_Encryption=0;AliasTable=;MeasureDimension=;Hint=;ConnectInit=;ArrayFetch=1;

In BO 4.0 system the function returns the following data

DB Layer: "Oracle OCI". DB Type: "Oracle 10".

Can you help us in obtaining the same data to be returned in BO 4.0 system as well ?

Also I was trying to obtain the web-i function for the universe connection name. Is there any web-i function where we can obtain this information directly?

Thank You.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Dec 11, 2014 at 03:20 PM

    Dear Arun,

    The behavior is different between XIR2 and BI4.0

    -> Connection() function in Web-I report does not show all the data like version, username, password, database and other connection parameters.

    It just shows the DB layer and DB type.

    ->In webi report Connection()

    function is now restricted to only shows the limited information about the

    connection.

    ->For security reasons, the output of the Connection() function no longer includes the database host name, user name, and user passw

    ord. The modification has been done under ADAPT01351265.

    ->Now Connection Function only includes information on

    DB Layer and DB type. The behavior is same in XI 3.1 and BI 4.0 (All

    patches)

    Please see this KBA "1532736 - Connection() function doesn't return all the connection
    information in Web Intelligence
    "

    thanks,

    Ameni

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.