Skip to Content

Something Wrong in Master Slave Afaria Design

Hi, I try to set up and master-slave afaria environment.

I have two Afaria Server in two different location

AfariaPNB (Master) : 10.40.1.212

AfariaKMP (Slave) : 10.96.1.212

And there are two Relay server on same location's DMZ.

AfariaRelayPNB (In front of Master Afaria) : rs2.yasar.com.tr (172.31.255.88)

AfariaRelayKMP (In front of Slave Afaria) : rs3.yasar.com.tr (172.31.254.88)

I can run RSOEs from master afaria to its First server. But after 20 sec later connection drops.

I can run RSOE from slave afaria to Firt Relay Server. But after 20 sec later conenction drops

here is Configurations:

Both Relay Server have same config:

rs.config:

#-------------------------------------
# Relay server options
#-------------------------------------
[options]
#start = no
verbosity = 3

#--------------------
# Relay server peers
#--------------------
[relay_server]
enable = yes
host = rs2.yasar.com.tr
http_port = 5007
https_port = 443
description = Machine #1 in RS farm

[relay_server]
enable = yes
host = rs3.yasar.com.tr
http_port = 5007
https_port = 443
description = Machine #2 in RS farm

#---------------
# Backend farms
#---------------
[backend_farm]
enable = yes
id = YASAR-IS2
client_security = off
backend_security= off


#-----------------
# Backend servers
#-----------------
[backend_server]
enable = yes
farm = YASAR-IS2
id = 4i5pih
token = YASAR-IS2


[backend_server]
enable = yes
farm = YASAR-IS2
id = 4i5bc9
token = YASAR-IS22

#---------------
# Backend farms
#---------------
[backend_farm]
enable = yes
id = es-afaria2
active_cookie = no
backend_security= no
description = Enrollment Farm

[backend_server]
enable = yes
farm = es-afaria2
id = es-afaria2
description = Enrollment Server #1

[backend_server]
enable = yes
farm = es-afaria2
id = es-afaria22
description = Enrollment Server #2
#---------------
# Backend farms
#---------------
[backend_farm]
enable = yes
id = ps-afaria2
active_cookie = no
backend_security= no
description = Portal Package Farm

[backend_server]
enable = yes
farm = ps-afaria2
id = ps-afaria2
description = Package Server #1

[backend_server]
enable = yes
farm = ps-afaria2
id = ps-afaria22
description = Package Server #2

Master server rsoe.config:

-id 4i5pih

-f YASAR-IS2

-t YASAR-IS2

-cs "host=10.40.1.212;port=81;"

-cr "host=172.31.255.88;port=5007;url_suffix=/ias_relay_server/server/rs_server.dll"

-q

-o c:\Temp\rsoe.log

Slave Server rsoe.config:

-id 4i5bc9

-f YASAR-IS2

-t YASAR-IS22

-cs "host=10.96.1.212;port=81;"

-cr "host=172.31.255.88;port=5007;url_suffix=/ias_relay_server/server/rs_server.dll"

-q

-v 5

-o c:\Temp\rsoe.log

And here is log files:

Master Afaria RSOE log:

I. 2014-11-27 14:23:16.822+0200 Character encoding: windows-1252

I. 2014-11-27 14:23:16.822+0200 SAP Sybase Outbound Enabler Version 16.0.0.1824

I. 2014-11-27 14:23:16.822+0200

I. 2014-11-27 14:23:16.822+0200 Copyright © 2014 SAP AG or an SAP affiliate company.

I. 2014-11-27 14:23:16.822+0200 All rights reserved.

I. 2014-11-27 14:23:16.822+0200 Use of this software is governed by the Sybase License Agreement.

I. 2014-11-27 14:23:16.822+0200 Refer to http://www.sybase.com/softwarelicenses.

I. 2014-11-27 14:23:16.822+0200

I. 2014-11-27 14:23:16.824+0200 <OEHost>

I. 2014-11-27 14:23:16.824+0200 <OEHost> SAP Sybase Outbound Enabler Version 16.0.0.1824

I. 2014-11-27 14:23:16.824+0200 <OEHost> Machine AFARIAPNB is running Windows 2008R2 Build 7601 Service Pack 1

I. 2014-11-27 14:23:16.824+0200 <OEHost> Software built for X86_64

I. 2014-11-27 14:23:16.824+0200 <OEHost>

I. 2014-11-27 14:23:16.827+0200 <OEMaster> Successfully connected to backend server: 10.40.1.212:81

I. 2014-11-27 14:23:16.859+0200 Successfully connected to relay server: rs2.yasar.com.tr:5007

I. 2014-11-27 14:23:16.866+0200 Successfully connected to relay server: rs2.yasar.com.tr:5007

I. 2014-11-28 10:30:42.765+0200 Waiting on OEMaster thread to terminate..

I. 2014-11-28 10:30:44.170+0200 OEMaster thread terminated.

I. 2014-11-28 10:41:14.612+0200 Character encoding: windows-1252

I. 2014-11-28 10:41:14.612+0200 SAP Sybase Outbound Enabler Version 16.0.0.1824

I. 2014-11-28 10:41:14.612+0200

I. 2014-11-28 10:41:14.612+0200 Copyright © 2014 SAP AG or an SAP affiliate company.

I. 2014-11-28 10:41:14.612+0200 All rights reserved.

I. 2014-11-28 10:41:14.612+0200 Use of this software is governed by the Sybase License Agreement.

I. 2014-11-28 10:41:14.612+0200 Refer to http://www.sybase.com/softwarelicenses.

I. 2014-11-28 10:41:14.612+0200

I. 2014-11-28 10:41:14.614+0200 <OEHost>

I. 2014-11-28 10:41:14.614+0200 <OEHost> SAP Sybase Outbound Enabler Version 16.0.0.1824

I. 2014-11-28 10:41:14.614+0200 <OEHost> Machine AFARIAPNB is running Windows 2008R2 Build 7601 Service Pack 1

I. 2014-11-28 10:41:14.614+0200 <OEHost> Software built for X86_64

I. 2014-11-28 10:41:14.614+0200 <OEHost>

I. 2014-11-28 10:41:14.618+0200 <OEMaster> Successfully connected to backend server: 10.40.1.212:81

I. 2014-11-28 10:41:14.650+0200 Successfully connected to relay server: rs2.yasar.com.tr:5007

I. 2014-11-28 10:41:14.656+0200 Successfully connected to relay server: rs2.yasar.com.tr:5007

E. 2014-11-28 10:41:35.672+0200 OEE1030: The Outbound Enabler was unable to connect to the Relay Server using 'host= rs3.yasar.com.tr;port=5007;url_suffix=/ias_relay_server/server/rs_server.dll;' because of [MLC63: Unable to connect a socket. Network Error: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. (winsock error code: 10060).]. Retrying. ..

Slave Afaria RSOE log:

I. 2014-11-28 11:18:15.919+0200 Character encoding: windows-1252

I. 2014-11-28 11:18:15.919+0200 SAP Sybase Outbound Enabler Version 16.0.0.1824

I. 2014-11-28 11:18:15.919+0200

I. 2014-11-28 11:18:15.919+0200 Copyright © 2014 SAP AG or an SAP affiliate company.

I. 2014-11-28 11:18:15.919+0200 All rights reserved.

I. 2014-11-28 11:18:15.919+0200 Use of this software is governed by the Sybase License Agreement.

I. 2014-11-28 11:18:15.919+0200 Refer to http://www.sybase.com/softwarelicenses.

I. 2014-11-28 11:18:15.919+0200

I. 2014-11-28 11:18:15.921+0200 <OEHost>

I. 2014-11-28 11:18:15.921+0200 <OEHost> SAP Sybase Outbound Enabler Version 16.0.0.1824

I. 2014-11-28 11:18:15.922+0200 <OEHost> Machine AFARIAKMP is running Windows 2008R2 Build 7601 Service Pack 1

I. 2014-11-28 11:18:15.922+0200 <OEHost> Software built for X86_64

I. 2014-11-28 11:18:15.922+0200 <OEHost>

I. 2014-11-28 11:18:15.931+0200 <OEMaster> Successfully connected to backend server: 10.96.1.212:81

I. 2014-11-28 11:18:15.955+0200 Successfully connected to relay server: rs2.yasar.com.tr:5007

I. 2014-11-28 11:18:15.969+0200 Successfully connected to relay server: rs2.yasar.com.tr:5007

E. 2014-11-28 11:18:36.976+0200 OEE1030: The Outbound Enabler was unable to connect to the Relay Server using 'host= rs3.yasar.com.tr;port=5007;url_suffix=/ias_relay_server/server/rs_server.dll;' because of [MLC63: Unable to connect a socket. Network Error: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. (winsock error code: 10060).]. Retrying...

What I did, My all RSOE's from master or Slave try to connect toFirs relay server. Is it correct?

Hre is Device communication Configuration page:

Master Afaria Server Devicecommunication page:

Slave Afaria Server Devicecommunication page:

What is wrong in my configuration?

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Posted on Dec 01, 2014 at 11:46 AM

    Yes, they both should connect to the first relay. What version of relay server is this? Is it windows or Linux? Is the IIS/Apache listening on 5007 in netstat when the relay server service is started? There isn't a firewall blocking 500 between these two servers is there?

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 01, 2014 at 01:59 PM

    Now I start to go step by step.

    First , I change my rs.config file to conenct only server communications.

    Both afaria servers can connect to "first" realy server.

    I need to know where I connect enrollment RSOEs to wich server?

    Master Afaria RSOEs ( enrollment and package server rsoe) should connect only "First Relay" server? or both Relay Servers?

    Likewise, Slave afaria RSOEs should conenct only "Second Relay" serveri or master server or both?

    Add a comment
    10|10000 characters needed characters exceeded

    • Both Afaria servers connect to relay 1. Once relay 1 connect to relay 1, that relay tells them there are peer relays and to disconnect and reconnect to relay 1 and 2. This happens automatically. Currently from your log, it looks like they aren't succeeding on the connection to relay 2. Since you are using the IP in the RSOE, make sure that the two Afaria servers can actually reach rs3.yasar.com.tr on post 5007. You may want to try and put the IPs in the rs.config instead of the relay server DNS names.

      Tracy

  • Posted on Dec 01, 2014 at 03:53 PM

    THnx Tracy,

    Now there is 6 RSOE connected to Relay 1

    3 from Master 3 from Slave.

    What I have to do if Master afaria goes down

    or Relay 1 Goes down?

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 04, 2014 at 01:50 PM
    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.