Skip to Content
author's profile photo Former Member
Former Member

NAV And DIS attribute don't match

Hello experts,

I'm quite new to BW/BI and i stumbled upon a problem in BI Analysis.

In a report/query there is a Free Characteristic 'Geplande startdatum' (cfr. Planned starting date) as well as a attributes 'Geplande startdatum' (cfr. Planned starting date). The source of both is 0PROJECT.

The problem is that the value's for both should be the same, yet there not.

I added a screenshot to elucidate the problem. What could be the problem here?

Thanks in advance!

Example.jpg (35.1 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

6 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Nov 26, 2014 at 01:50 PM

    Any specific reason why you expect the display attibute and navigational attribute to display the same value?

    They are different in nature, so i think it is not an issue itself on the front end but rather a modeling question in the backend side.

    Best would be to check with your BW developer of trust.

    Add a comment
    10|10000 characters needed characters exceeded

    • Hello Vander,

      agree with the previous response here - just because these two items are based off the same InfoObject, that does not automatically mean that you should expect the same values.

      Did you test your Query in Transaction RSRT to see the values there ?

      You mentioned you changed the Display Attribute to be a navigational attribute. That would mean you should not see the Display Attribute anymore and only see the Navigational attribute. So I assume the cube has the display attribute and the navigational attribute and then those can have different values.

      regards

      Ingo Hilgefort, SAP


  • Posted on Nov 26, 2014 at 12:35 PM

    Hi Vander - what version of Analysis Office is this?

    Does it give similar behavior when you try this with BEx Analyzer?

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 26, 2014 at 01:13 PM


    Hello Tammy!

    I'm working with v1.4.8.3163. Unfortunately I can't check this in Bex Analyzer...

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 27, 2014 at 03:15 AM

    both these attributes loaded from same source field?

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 27, 2014 at 08:37 AM

    They both appear to have the source field 'ZPS_PLSD9'.

    That's why assumed that they would have the same data.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 08, 2014 at 09:56 AM

    Hi Vander,

    I suspect you attribute is time dependent and you use different time stamps for reading the navigation attribute and the display attribute.

    regards

    Cornelia

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.