Skip to Content

Recovery not working

Hello All

In a simple scenario of creating new system with backup of old system the HANA studio is not responding.

1. Both the instances are on AWS

2. Both the instances are on Rev66

3. HANA studio is also Rev66 version

Steps performed:

1. Taken the backup from source system

2. Copied over to new system, changed permissions of the files and tried recovering from HANA Studio.

Studio runs for a minute and does nothing, and says as below:

st.JPG

st1.JPG

Tried to recover my command line as below, the recovery says it's completed and after couple of minutes the HANA system goes down and doesn't come up.

hanaserver:/usr/sap/HDB/HDB00> HDBSettings.sh recoverSys.py --command "recover data using file ('ASOF_NOV20_1635PST') clear log"

[140380360279808, 0.004] >> starting recoverSys (at Thu Nov 21 05:42:22 2013)

[140380360279808, 0.004] args: ()

[140380360279808, 0.004] keys: {'command': "recover data using file ('ASOF_NOV20_1635PST') clear log"}

own pid: 10424

Enter the password of user hdbadm :

recoverSys started: 2013-11-21 05:42:32

testing master: hanaserver

hanaserver is master

shutdown database, timeout is 120

stop system

stop system: hanaserver

stopping system: 2013-11-21 05:42:32

stopped system: 2013-11-21 05:42:56

creating file recoverInstance.sql

restart database

restart master nameserver: 2013-11-21 05:43:11

start system: hanaserver

2013-11-21T05:43:15+00:00  P011846      142792f063d INFO    RECOVERY state of service: nameserver, hanaserver:30001, volume: 1, RecoveryExecuteTopologyAndSSFSRecoveryFinished

recoverSys finished successfully: 2013-11-21 05:43:17

[140380360279808, 55.101] 0

[140380360279808, 55.101] << ending recoverSys, rc = 0 (RC_TEST_OK), after 55.097 secs


Can you advise here what are the other ways we can do the recover and why Studio is not picking up the recovery.


When browsed through the trace, I could find the below clue:


[11375]{-1}[-1/-1] 2013-11-21 05:46:13.929315 i Daemon       TrexDaemon.cpp(11147) : comment file contains: nameserver: previous recovery incomplete: volume: 3 is in state: RecoveryLogInitializationFinished volume: 4 is in state: RecoveryLogInitializationFinished volume: 2 is in state: RecoveryLogInitializationFinished

stop process hdbstatisticsserver with pid 11971

Does this mean the recovery from command line was not successful ?


Adding the below error screenshot from studio while I recover the system:



Thanks

Srikar

pastedImage_0.png (19.6 kB)
st1.JPG (17.6 kB)
st.JPG (17.8 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Nov 22, 2013 at 11:24 AM

    Hi All

    I have launched one more new instance and copied over the latest backup files to new machine and tried to recover from studio, but I am ending up with below error:

    Untitled.jpg

    2013-11-22T07:31:15+00:00 P058934      1427eb57f3a ERROR   RECOVERY RECOVER DATA finished with error: [448] recovery could not be completed, volume 2, reached log position 0, [110044] The service 'indexserver' at 'hanaserver:30003' responsible for the volume '2' does crash


    So this means is there any issue with the backup files we have taken from our existing Dev system ?

    Thanks

    Srikar


    Untitled.jpg (45.6 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member


      HI Srikar,

      According to my understanding, there are some log backup running in the machine that you are performing recovery .

      Before recovery, you need to ensure that

      HDB is stoped completely , all backup's should be stopedĀ  and you Application also should be stoped.

      After completing this, perform the recovery again. if it doesnt work , thwn please send me

      recoverstart.trc

      Regards,

      Pavan Gunda