Skip to Content
author's profile photo Former Member
Former Member

Sender Channel SFTP - Exception received: java.lang.StringIndexOutOfBoundsException: String index out of range: -1

Hi, Experts

We have an issue in our SFTP to RFC scenario. The sender communication channel is showing an error when the option "Arquiving on SFTP Server" is selected (Exception received: java.lang.StringIndexOutOfBoundsException: String index out of range: -1). Below the print of configuration and the log error. We have checked the connection and it is ok, the user has full access to the directory and the file content was tested. We try to send an empty file as well but the same error occour.

Is there a module problem? Do someone have passed by the same problem?

P.S. If the option "Archive Files on SFTP Server" is unchecked the file is processed with success.

Error log:

Thanks,

Halsen

channel1.png (21.5 kB)
channelLog1.png (48.3 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Dec 05, 2014 at 06:29 PM

    Hi All,

    We've decided to open an Incident on SAP Service.

    They answer was to install the sap note below.

    2049494 - Renaming archived files with proper nomenclature in SFTP adapter


    The basis team will deploy it.


    Thanks all for the support.


    Regards,

    Halsen



    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 19, 2014 at 02:08 PM

    Hi Halsen,

    Please check the file naming convention also. The file extension is missing in the file name. You cannot create a file without an extension. Change it and then try. It will work.

    Regards,

    -Partha

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Partha,

      We tryed changing the extension file name as .txt and it worked.

      But why the file is processed even without the file extension when the arquive flag is unchecked?

      Theoretically, it wans't to work as well...

      Do you think there are other solution because we can't change the extension file.

      Regards,

      Halsen

  • author's profile photo Former Member
    Former Member
    Posted on Nov 19, 2014 at 12:54 PM

    Hi Halsen,

    Please check the "path" (location) that you have provided to archieve. It seems that either the path is incorrect or the user needs authorization to write a file there.

    Regards,

    -Partha

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 19, 2014 at 07:43 PM

    We verified that is not necessary a extension in the file but just a "." (dot) in any place of

    the file name the channel process the file with success.

    We are using the mask .*._cb_.*.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.