Skip to Content
author's profile photo Former Member
Former Member

/XNFE/NFE_TRANSFORMER - XML value: Qcom not getting correctly filled in items table

Hello experts,

In NF-e, the standard function module /XNFE/NFE_TRANSFORMER does not return the correct value of the quantity field 'qCom' from the XMl file into the items internal table (et_innfeit). If the quantity is 100.00, it just comes as 0. This has does not used to happen before back in 2012.

While debugging the standard FM, the sy-subrc check fails at the location as shown in the attached image.

Could you please advice what has changed in the recent times in this FM and if any notes are relevant?

Help will be rewarded.

Thank you.

Regards,

Utkarsha

debug.jpg (126.0 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Dec 13, 2014 at 04:54 PM

    Bom dia Utkarsha,

    O conteúdo deste espaço é em língua Portuguesa.

    Para ler as mensagens ou postar use o Google Translator que funciona muito bem entre estas duas linguas.

    https://translate.google.com/translate?sl=pt&tl=en&js=y&prev=_t&hl=pt-BR&ie=UTF-8&u=http%3A%2F%2Fscn.sap.com%2Fthread%2F…

    Thread bloqueada.

    Atenciosamente, Fernando Da Rós

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.