Skip to Content

value in .csv file getting replaced with zeroes

Hi,

My scanario is from ECC-->file and .csv file is created in folder.but when one field is sent as numeric the first digit 0 is trimmed and last 4 digits rae trimmed and zeroes are added.I use the following configuration in receiver FCC.

value from ECC

ACC Document no--033914053300000010001

value displayed after processing from PI in .CSV file--33914053300000000000

when we send only numeric values this problem is occuring and if it contains even one alphabet the value is coming right

1.JPG (44.7 kB)
2.JPG (28.7 kB)
3.JPG (55.8 kB)
4.JPG (34.6 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Nov 18, 2014 at 10:06 AM

    Hi Gurudattta,

    You have used .fieldSeparator along with .fieldFixedLengths, which is conflicting as per file content conversion.

    Also, the fixed length that you have supplied, which is 50,  does not match with the ACC Document number field.

    If you are not sure of the field lengths then I would advise you to use only the .fieldSeparator parameter.

    Regards,

    Alka Panday.

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 18, 2014 at 02:04 PM

    Hi Guys,

    I removed the field separator ; from the FCC i copuld see the correct value displayed in the .csv file but

    The columns are not separated  by each other (A,B,C,D) columns

    new output:

    old output:


    5.JPG (35.8 kB)
    4.JPG (34.6 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Gurudatta,

      As per requirement, you should keep the field separator parameter, but in field length maintain correct values.

      Also, if the last column is not required in the file, then you should manage in the message mapping logic.

      Regards,

      Alka Panday.

  • Nov 19, 2014 at 01:48 PM

    Hi everyone,

    I removed the company code field from mapping which i do not wanted to show in the .csv file

    this is done. and i have written the UDF to create the file appended by company code-done

    LBGVPFVPFPAR_0339(company code)20141119-143543-699(time stamp).csv---done

    and i have done following simple configuration in FCC but still the generated csv file showing incorrect values

    Z_ACNTDOC_NUMB--value sent from ECC--033914053300000009001

    but value displayed in .csv file--33914053300000000000(wrong)

    0-trimmed and 9001 trimmed


    19112014.JPG (32.3 kB)
    1.JPG (46.8 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • Nov 20, 2014 at 06:59 AM

    Hi everyone,

    I removed the company code field from mapping which i do not wanted to show in the .csv file

    this is done. and i have written the UDF to create the file appended by company code-done

    LBGVPFVPFPAR_0339(company code)20141119-143543-699(time stamp).csv---done

    and i have done following simple configuration in FCC but still the generated csv file showing incorrect values

    Z_ACNTDOC_NUMB--value sent from ECC--033914053300000009001

    but value displayed in .csv file--33914053300000000000(wrong)

    0-trimmed and 9001 trimmed


    1.JPG (46.8 kB)
    19112014.JPG (32.3 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • Hi Guru,

      Can you give the screenshot of your Data Type that your created for FCC.

      Also as suggested by Hareesh, seems issue with the MS office version.

      Can you try to  use the format cell option and changing the settings to general etc in your CSV file to check if its having correct values?


      Regards,

      Azhar