Skip to Content
0

UJO_READ_EXCEPTION_018 - Runtime error SQL error ssing program CX_RS_SQL_ with parallel processing

Jan 25, 2017 at 08:04 PM

106

avatar image

Hello Gurus,

I have a problem when I am refreshing a Report. Here is what I happened:

I have 10 dimension in my Model: Entity, Currency, PERIODO, Assumptions, Category, Profit Center, Cost Center, Accounts, Company Code and ZSTAGL.

The dimension PERIODO was a shared dimension with other model, I had to make some changes to that dimension so I decided to create the new Dim PERIOD0. So I created de dimension, get it in to the model and have the problem that now when I try to refresh a Report I got the next message:

I have tried to do a lot of thing that I have fond: Clearing the CACHE from EPM and from UJ tcode, I even activate and deactivate the ENVIRONMENTSHELL. I put back the original dimension, I checked the dimension Formula and its the same as the ENVIRONMENTSHELL. After some testing, I found out the next:

I was using the formula EPMDimensionOverride in the template I am having the problem with. When I delete the formula and set the PERIODO from Edit Report, the report seems to work fine, when I write the formula I got the message posted above.

What els can I do?? ;S

Sys info:

message.jpg (92.6 kB)
sys-info.png (33.4 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Vadim Kalinin Jan 25, 2017 at 08:09 PM
1

Screenshot of you PERIODO dimension administration!

Text of dimension formula with explanation!

Show 4 Share
10 |10000 characters needed characters left characters exceeded

Thaks for the post Vadim,

Here is the Dimension scrrenshot:

The Formula I have on Cell B11 is:

=EPMDimensionOverride("000","PERIODO",A25)

In A25 I have concatenated 01.2016, 02.2016, 03.2016.......12.2016 (the 2016 the year of the user selection in the context, I just get the year of any selection to display all the month of the year).

This worked just fine before the change I mentioned in the post.

periodo.jpg (121.8 kB)
0

Sorry, but I want to see all members of PERIODO dimension for one year... including parent members etc...

Do you always have 3 level structure of PERIODO members? Do you have any special PERIODO members?

0

P.S. It's a bad idea in general to use Zero - 0 instead of letter "O" - users will always get confused!!!

0

Vadim,

Here is the screenshoot of one year. I don't have any special periods, just a dummy member is called NA. The structure is Month, Quarter, Year. Always.

I deleted the dimension PERIOD0 (with zero at the end) I went back to use the original PERIODO.

1-year.jpg (71.1 kB)
other.jpg (134.7 kB)
0
Vadim Kalinin Jan 25, 2017 at 08:49 PM
0

"just a dummy member is called NA" - absolutely bad idea! All members in TIME dimension has to be in 3 level structure!

Show 3 Share
10 |10000 characters needed characters left characters exceeded

I just deleted the dimension member and tested again but there is no difference :S. It was working befor the change I made :S.

0

Looks like you need more tests. With the correct TIME dimension - no issues.

1

Hello Vadim,

I was searching for a Solution, I didn't want to apply note 2283395 - SQL5702 error returned from BPC report terminating with SQL30046 error - SAP BW on ASE, but Basis applied it.

It solved the problem. In addition, while Basis was applying the note I construct another identical model with no problems.

Thanks for the posts.

Best Regards.

1