Skip to Content
0
Former Member
Nov 06, 2014 at 08:11 AM

RSFTP002 file size zero issue

272 Views

Hi All,

I wanted to download a csv flat file from ftp server to BW application server using RSFTP002 program.

I can see the file on AL11 - DIR_HOME directory but file size is 0 byte!!


RSFTP002 parameters are;

User.., password.., host..,

Command 1: get ***.csv

RFC Destination: SAPFTPA

Compress: N

and program returns that;

200 Port command successful

150 Opening data channel for file transfer.

Accept on data channel failed : NIETIMEOUT timeout 720000 ms

TCP/IP error, connection terminated

Zero sized csv file permissions are;

Owner: read,write-ok / execute-no

Group: read, write-ok / execute-no

General: read, write, execute-no

owner is <System ID>adm, group is sapsys.

I searched the forum,

- SAPFTPA connection tested via SM59, no problem.

- Changed Activation type Start on Application Server to Start on Explicit Host, not solved.

- Opened firewall port 20 and 21, not solved.

- sapftp.exe file located on as it should be.

... any other suggestions???