Skip to Content
avatar image
Former Member

Error DBServerType SAP 9 DI API: Database server type not supported (-119)

Hello,

I have the following problem;

...in DI API version 8.82 PL11 can usually connect via PHP:

$oComp = new COM("SAPbobsCOM.Company") or die("No connection");

$oComp->Server="IP\\INSTANCE";

$oComp->LicenseServer = "IP:Port";

$oComp->DbUserName = "user";

$oComp->DbPassword = "****";

$oComp->DBServerType = "7";

$oComp->UserName = "user";

$oComp->Password = "****";

$oComp->CompanyDB = "SBODemoUS";

try {

    echo $oComp->Connect;

    echo "<br><br>";

    $oComp->StartTransaction();

} catch (com_exception $expt) {

    echo $expt->getMessage();

    echo "<br><br>" . $oComp->GetLastErrorDescription;

}

Note: MSSQL2012

In the case DI API 9.0 PL13 features the same connection the following error:

-119

Source: SAPbobsCOM.Company.90.0

Description: You are not connected to a company

Database server type not supported

Note: Both cases IIS environment

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 29, 2014 at 01:02 AM

    Hi Eric,

    In addition to adding

    [PHP_COM_DOTNET]

    extension=php_com_dotnet.dll

    to your php.ini file, you have to tell PHP where to look for the extension, and to enable extensions.

    Where to look for extensions (Windows):

    uncomment (remove the leading ";")

    extension_dir = "ext"

    <<<<<< OK up here!

    Enable extensions:

    Set the enable flag to On:

    enable_dl = On

    The problem was exactly the activation of this extension

    Regards, Lucio

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 29, 2014 at 12:19 AM

    What kind of permission you applied?

    What other settings you made in IIS environment?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      As I said, I changed the permissions on the PHP folder and wwwroot, to give full access to users and the IUSR_.

      In IIS at the end, I changed nothing: just removed all my tests with PHP, IISReset from the command line, and reconfigure properly the PHP FastCGI interface.

      Regards,

      Eric

  • avatar image
    Former Member
    Oct 26, 2014 at 07:15 PM

    Hi Lucio,

    Since V9.0 in one case and 8.82 in the other: using 32 bits (with the corresponding DI-API) processes in both cases?

    Regards,

    Eric

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Sorry,I'm trying to understand.

      SQL-Server is not the issue, else I would be really surprised.

      I have read somewhere, that for fatsCGI and COM invocation, it was better to go down to PHP 5.3 and in all cases for a thread unsafe version.

      Is it something you can try?

      I'm having trouble to create COM objects from PHP to test your problem. Before I'm spending my night on it, do specific setting have to be put Inside the php.ini file?

      Regards,

      Eric

  • avatar image
    Former Member
    Oct 28, 2014 at 10:49 PM

    Eric, In all the versions I'm being 5.3 to 5.6 have the same problem.

    The version 8.82 is functioning normally in this environment - and the version 9 also worked in the old environment.

    Not mentioned, but the old environment is W2k8 with the new environment and W2012.

    The problem is not necessarily the SQL Server, but the native client or Windows itself. Because the version of the OS is 64bit - observe a small problem, but have not found the real problem.

    hugs, Lucio

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Yes, but with a named instance...

      I don't remind which, but there is one of the components of the Platform which doesn't accept named instances. Not the same component, I know, but the issue is similar.

      May you use the c:\windows\SysWOW64\cliconfg.exe program, to create a local alias to your instance, and in the server field, to use this alias instead of the IP-DNS\INSTANCE?

      Regards,

      Eric