Skip to Content
avatar image
Former Member

Communication between ECC and SCM via XI

I am trying to set up the scenario 'Purchase_Order_Processing' between

ECC and SCM using XI. The SCM content for XI has been loaded into XI

and this scenario is included in the content.

We are running the following:

ECC - Version 5.0 - 640 SP level 12

XI - Version 3.0 - 640 SP Level 14

SCM - 4.10 - 640 SP Level 12

The connectivity between the systems has been set up as described in the configuration guides. On sending an IDOC (basic type ORDERS05) into XI I get the following error message 'Http server code 500 reason Internal Server Errorexplanation Error during parsing of SOAP header'.

The Error XML is as follows:

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

- <!-- Call Adapter

-->

- http://sap.com/xi/XI/Message/30"

xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/"

SOAP:mustUnderstand="">

<SAP:Category>XIAdapter</SAP:Category>

<SAP:Code area="PLAINHTTP_ADAPTER">ATTRIBUTE_SERVER</SAP:Code>

<SAP:P1>500</SAP:P1>

<SAP:P2>Internal Server Error</SAP:P2>

<SAP:P3>Error during parsing of SOAP header</SAP:P3>

<SAP:P4 />

<SAP:AdditionalText />

<SAP:ApplicationFaultMessage namespace="" />

<SAP:Stack>Http server code 500 reason Internal Server Error

explanation Error during parsing of SOAP header</SAP:Stack>

<SAP:Retry>M</SAP:Retry>

</SAP:Error>

Any assistance would be much appreciated.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Jan 06, 2006 at 09:31 AM

    Hi Richard..

    I am facing same problem. Your help may serve our purpose.

    Regards,

    Vinod

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 06, 2006 at 02:01 PM

    Can you please provide some more details?

    Is it Idoc to http scenario?

    Are you seeing the dump in sxmb_moni at the reciever side?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Was there a solution for this issue? May be you want to use XI protocol between XI and SCM (ICH). The reason why you are getting HTTP 500 is because, the local IE on SCH may not be setup correctly.