Skip to Content
0

Error installing SHINE for SAP HANA XS Advanced Model on HANA 2.0, express edition

Jan 25, 2017 at 10:17 AM

942

avatar image

Dear experts,

has anyone already successfully installed the SHINE for SAP HANA XS Advanced Model on their HANA 2.0, express edition?

When trying to install the version that comes with the HANA 2.0, express edition everything looks fine to start with but then I get the following error:

Error creating services: Controller operation failed: Could not create service "shine-user-container": Could not create service shine-user-container (hana, plan hdi-shared): Provisioning service shine-user-container (service id 5cfa4f1a-32fc-4d97-9076-a12988941c52, plan id d7c2658a-2198-41f3-8f4c-81741b7a183d) on service broker "hdi-broker" (url: https://hxehost.dyndns.org:39032/hdi-broker) failed due to unexpected return code from broker: Failed to create HDI container.
Installation failed during deployment.

Installation of archive file(s) 'XSACSHINE02_2.ZIP' failed.
To see installation logs execute 'xs display-installation-logs 2701 -scv'.
com.sap.lm.sl.alm.core.monitor.ProcessException: Error creating services: Controller operation failed: Could not create service "shine-user-container": Could not create service shine-user-container (hana, plan hdi-shared): Provisioning service shine-user-container (service id 5cfa4f1a-32fc-4d97-9076-a12988941c52, plan id d7c2658a-2198-41f3-8f4c-81741b7a183d) on service broker "hdi-broker" (url: https://hxehost.dyndns.org:39032/hdi-broker) failed due to unexpected return code from broker: Failed to create HDI container.
Installation failed during deployment.

Please find the mentioned installation log attached.

Any experience or help with this would be very much appreciated.

Best regards

Frank

10 |10000 characters needed characters left characters exceeded
Former Member

Hi Frank,

Can you provide the below information

1. Do you have SHINE installed in any other spaces?

2. In the mtaext file what is the <SCHEMA_NAME> which was given for shine-user-container.

Thanks in advance.

Regards,

Shankari G R

0

Hello Shankari,

Thank you in advance for your help. Concerning your questions:

  1. No, SHINE is not installed in another space.
  2. The shine-user-container schema is XSA_SHINE (please find the full mtaext file attached).

Best regards

Frank

0
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
avatar image
Former Member
Feb 07, 2017 at 09:59 AM
0

Hello Frank,

Thanks for your inputs.

In the above sap-xsac-shine-122-xsacshine02-2mtaext.txt, user name used for creating the User Provided Services and the schema name in SHINE_USER_CONTAINER are same (XSA_SHINE). This is the cause for this issue.

Please follow the below steps for reinstalling SHINE:

1. Change the schema name for SHINE_USER_CONTAINER in your mtaext file(curently schema name is XSA_SHINE). Change it say SHINE_USER_SCHEMA

2. Delete all the services and then try reinstalling SHINE.

3. If the SHINE installation fails with a message that the SHINE version is already installed or cannot be downgraded, reinstall SHINE with the below command:

xs install XSACSHINE01_<version.no>.ZIP -e sap-xsac-shine-1.2.xx.mtaext –o ALLOW_SC_SAME_VERSION

xs install XSACSHINE01_<version.no>.ZIP -e sap-xsac-shine-1.2.xx.mtaext –o ALLOW_SC_DOWNGRADE

Please feel free to get back to us in case of clarifications.

Thanks and Regards,

Shankari G R

Show 6 Share
10 |10000 characters needed characters left characters exceeded

Thank you Shankari,

With changing the schema, the shine-user-db installs fine.

However, now the shine-core-db installation times out:

Would you have an idea what could cause this?

Very best regards

Frank

timed-out.png (34.8 kB)
0
Former Member

Hi Frank,

Can you execute the below command and send me the logs file?

xs logs shine-core-db --recent

Thanks and Regards,

Shankari G R

0

Thank you for your help so far, Shankari.

Please find the requested log attached. There seems to be an authentication issue, but I do not understand where this is comming from, since the user name and password in the .mtaext file are correct.

Very best regards

Frank

0

Hello Shankari,

I solved the issue with the missing authentication. It was due to a wrong port number for SQL/MDX access standard access to the system database, because the HANA, express edition is a multitenant system. Therefore the port number is 3NN13 rather than 3NN15.

Many thanks for your help again

Frank

0
Former Member
Frank Schuler

Hi Frank,

Could you share the experience how you solved the issue of port/authentication? I got a same one I think

Starting application "shine-core-db" timed out

And it let me check the log with command 'xs display-installation-logs 3104 -scv'. But I can't execute it in my system.

Best regards,
Thanks,

0
Former Member

Hello Frank,

Thanks for you update and I am glad that you were able to fix your issue.

Thanks and Regards,

Shankari G R

0
Jean-Christophe BRUN Sep 14, 2017 at 04:23 PM
0

Hello,

I just ran into almost the same issue with Shine installation, except that whatever I put in the mtaext file in schema, it fails at the end of installation:


Running installation in org "HANAExpress" / space "SAP" as XSA_ADMIN...
Upload into container starts...
Container ID: 5717afdb-5551-4516-ab78-d2fd4ae4c992
Software Component
-------------------------------
name XSAC_SHINE
vendor sap.com
version 1.2.4
-------------------------------
Upload into container finished successfully
Validation starts...
WARN The software component XSAC_SHINE (sap.com) 1.2.4 exists in broken state
Summary of what will be installed:
Software component XSAC_SHINE (sap.com) 1.2.4
Validation finished successfully
Product Installer log ID: 4501
Product Installer runtime version [1.10.7] built at [2016-11-22 08:32]
Check for availability of required services starts...
All required services are reachable.
Processing of archive starts...
Processing of archive finished.
Validation starts...
The software component XSAC_SHINE (sap.com) 1.2.4 exists in broken state
Summary of what will be installed:
Software component XSAC_SHINE (sap.com) 1.2.4
Validation finished.
Preparing content for deployment starts...
Deployment content prepared.
Now processing software component XSAC_SHINE (sap.com) 'SAP Hana Demo Model for XS Advanced 1.0'
Upload to deploy service starts...
Upload to deploy service finished.
Deployment starts...
Deployment in progress. Deploy service process ID: 7001
---------------- deploy service START------------------------------
Validating parameters...
Processing MTA archive...
Processing MTA extension descriptors...
Detecting MTA major schema version...
MTA schema version: 3.1.0
Detecting target platform...
Detected target platform "HANAExpress SAP"
Validating and merging descriptors...
Detecting deployed MTA...
Deployed MTA detected
Collecting system parameters...
Deployed MTA version: 1.2.2
New MTA version: 1.2.2
Resolving properties and parameters in merged descriptor...
Building cloud deployment model...
Building cloud undeployment model...
Validating services to create...
Service "shine-container" exists but doesnt have any bound applications
Service "shine-scheduler" exists but doesnt have any bound applications
Service "CROSS_SCHEMA_SYS" exists but doesnt have any bound applications
Service "CROSS_SCHEMA_SYS_BI" exists but doesnt have any bound applications
Service "shine-uaa" exists but doesnt have any bound applications
Validating applications to deploy...
Adding domains...
Deleting unused reserved routes...
Creating or updating services...
Service "shine-container" is not modified and will not be updated
Updating service "shine-user-container"...
Error creating services: Controller operation failed: Could not update parameters of service "shine-user-container" to "{}": Could not update parameters for service shine-user-container: Patching service shine-user-container to plan id plan id ddb1aaef-018a-44b5-a8c1-3a26d07f4218 on service broker "hdi-broker" (url: https://hxehost:39032/hdi-broker) failed due to unexpected return code from broker: REST request PATCH to url 'https://hxehost:39032/hdi-broker/v2/service_instances/87b03d7a-fcc4-416b-b9a2-ab5ead01502a' had response code 401 (Request from client was not authorized) with error message: ''.
---------------- deploy service END --------------------------------
Error creating services: Controller operation failed: Could not update parameters of service "shine-user-container" to "{}": Could not update parameters for service shine-user-container: Patching service shine-user-container to plan id plan id ddb1aaef-018a-44b5-a8c1-3a26d07f4218 on service broker "hdi-broker" (url: https://hxehost:39032/hdi-broker) failed due to unexpected return code from broker: REST request PATCH to url 'https://hxehost:39032/hdi-broker/v2/service_instances/87b03d7a-fcc4-416b-b9a2-ab5ead01502a' had response code 401 (Request from client was not authorized) with error message: ''.
Installation failed during deployment.

Installation of archive file(s) 'XSACSHINE02_4.ZIP' failed.
To see installation logs execute 'xs display-installation-logs 4501 -scv'.
com.sap.lm.sl.alm.core.monitor.ProcessException: Error creating services: Controller operation failed: Could not update parameters of service "shine-user-container" to "{}": Could not update parameters for service shine-user-container: Patching service shine-user-container to plan id plan id ddb1aaef-018a-44b5-a8c1-3a26d07f4218 on service broker "hdi-broker" (url: https://hxehost:39032/hdi-broker) failed due to unexpected return code from broker: REST request PATCH to url 'https://hxehost:39032/hdi-broker/v2/service_instances/87b03d7a-fcc4-416b-b9a2-ab5ead01502a' had response code 401 (Request from client was not authorized) with error message: ''.
Installation failed during deployment.

Any help please ?

Regards,

JC

Share
10 |10000 characters needed characters left characters exceeded