Skip to Content
0
Oct 08, 2014 at 10:29 PM

BI 4.1 SP1 CRWEB00000119 Error for Some Users

26 Views

Environment:

Windows 2012 Server

BI Platform 4.1 SP1

My client has some Crystal 2013 reports that use .unv universes to connect to an Oracle database. The universe connections are using the native Oracle connection. BOTH 32-bit and 64-bit Oracle 11g clients (11.2.0) are installed on the server.

Users in two user groups get the following error when trying to view reports:

The viewer could not process an event. Failed to open the connection. Universe Connection [] ---- Error code:0 [CRWEB00000119]

Users in two other user groups do not get the error. Webi reports work ok for all users and Crystal 2013 reports that connect directly to Oracle without the universe also work for all users.

This tells me that it's probably a security issue. So I compared the security for the four groups:

Universe Security

There is no object level security configured in the universe. For User Security, the two groups that can successfully view the reports have the "Create and edit queries based on the universe" right and the two groups who can't don't have this. Both groups have the "Data Access" right on the universe. When I add "Create and edit queries based on the universe" to the access levels that the bad groups are using, it does NOT resolve the issue.

Connection Security

All four groups have "Data Access" rights for Connections and Relational Connections. There are no stored procedures used in any of the universes so the Stored Procedure rights are not needed.

Object Security

The groups have the following access to the folders that contain the reports. Access is inherited down to the reports:

Bad

Group1

Bad

Group2

Good

Group1

Good

Group2

Crystal ReportsPrint the report's dataXXXXCrystal ReportsRefresh the report's dataXXXXCrystal ReportsExport the report's dataXXGeneralAdd objects to the folderXXGeneralCopy objects to another folderXXGeneralDelete instancesXXGeneralDelete instances that the user ownsXXGeneralDelete objectsXGeneralDownload files associated with the objectXXXXGeneralPause and Resume document instancesXXGeneralPause and Resume document instances that the user ownsXXGeneralReschedule instancesXXGeneralReschedule instances that the user ownsXXGeneralSchedule document to runXXXXGeneralSchedule on behalf of other usersXXXXGeneralSchedule to destinationsXXXXGeneralSecurely modify rights users have to objects that the user owns.XXGeneralView document instancesXXXX

I don't see anything here that would prevent that would cause the issue.

Is there something else I can check to try to fix this?

Thanks!

-Dell