Skip to Content
author's profile photo Former Member
Former Member

How to upgrade the Identity Centre from IDM 7.2 SP7 to SP8

Hi all,

I am currently working on SAP IDM 7.2 on NW 7.31.

The new task is to upgrade the SAP Identity center from version 7.20 SP7 to SP8 in sandbox system only.

The current version level which i found from Identity centre are

PRD -- Version 7.20.8 2014-02-28 720_REL

DEV -- Version 7.20.8 2014-02-28 720_REL

SBX -- Version 7.20.7 2013-06-06 720_REL

And when i login in to UI under component information, IDMFEDERATION component in Sandbox system is still running in 1000.7.2.7.0.20130108102054

Whereas same component patch level in Dev and Prod is 1000.7.2.8.0.20130508095747.

Other two below mentioned IDM components are already upgraded to sp8 in sandbox systems.

IDMIC ( 1000.7.21.8.3.20140206161124)

IDMPORTALCONT ( 1000.7.21.8.0.20130516153851)

And all other UI components are running in SP7 only.

I couldn't find any doc which explains about the SP upgrade from 7 to 8

All I could find is the fresh installation of Identity center components.

Can any one please let em know how to proceed on this.

Thanks

Vimal

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Oct 02, 2014 at 02:57 AM

    Hello Vimal,

    Following is my checklist during SP upgrade.

    1. Stop all dispatchers and event agents
    2. Uninstall the old DESIGNTIME and RUNTIME components
    3. From the new version folder locate the database folder and select your database type (SQL Server/Oracle/DB2)
    4. Run the appropriate upgrade script (check the Database specific PDF file for information on customization and detailed procedure) You'll probably need to engage your DBAs on this as well.
    5. Install the new DESIGNTIME and RUNTIME components
    6. Verify the new version is installed through the MMC Console (you should notice the change in version on the splash screen and then when you go into look at the ID Store
    7. Deploy the IDM UI, Federtion component to AS JAVA. (Both are .SCA files) - to know how to deploy the .SCA files to AS JAVA, please refer to Upgrading the Identity Management User Interface section of https://websmp207.sap-ag.de/~sapidb/011000358700001233082010E (SMP Login required)

    (You can seek your basis team help for deploying the .SCA files to AS JAVA)

    8. Restart your AS JAVA.

    9. Restart your dispatchers and event agents.

    But I can see you are specially looking at the UI & Federation components upgrading, for that pls refer to point 7.

    Let me know if that helps.

    ~ Krishna

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 02, 2014 at 08:28 AM

    Hello Vimal,

    I guess because installing IDM fresh and upgrading it are so similar, there is not much documentation needed (SAP thinks ^^).

    The only difference is pretty much, that you need to stop the dispatchers before updating. And instead of executing the "mxmc-install" you use the "mxmc-update".

    It sounds so easy on paper... *sign*

    @Krishna: Do you have better experience with uninstalling the former version first? Normally that shouldn't be necessary. 😊

    Regards,
    Steffi.

    Add a comment
    10|10000 characters needed characters exceeded

    • I guess, we should take all the safety nets we can lay our hands on with the updates. ^^

      Strangely enough, it wasn't mentioned in the training I attended two weeks ago. But I heard the same several times now. Maybe our update to SP8 wouldn't have blown to pieces like it did, if we uninstalled first (on the other hand, that update seems to have been a tricky one either way, because the consultant knew which update I meant, before I mentioned the number).

      I'll definitly do that the next time! 😊

  • Posted on Oct 02, 2014 at 12:24 PM

    Yes, always uninstall first.

    The thing to remember is that IDM is NOT AT ALL LIKE other SAP modules. Assuming that IDM works like other modules will result in bad things happening. Trust me, been there, done that, had to restore the backup 😊

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.