$(function () { pageContext.i18n.modTalk = 'moderation talk'; pageContext.i18n.replyToComment = 'Reply'; pageContext.i18n.modTalkEmpty = 'moderation talk is empty'; pageContext.url.getModTalk = "/comments/%25ID%25/listModTalk.json"; pageContext.url.possibleCommentRecipients = "/comments/%ID%/possibleRecipients.json"; pageContext.url.commentEdit = '/comments/%25ID%25/edit.html'; pageContext.url.commentView = '/comments/%ID%/view.html'; pageContext.i18n.commentVisibility = { 'full': 'Viewable by all users', 'op': 'Viewable by the original poster', 'mod': 'Viewable by moderators', 'opAndMod': 'Viewable by moderators and the original poster', 'other': 'Advanced visibility', 'dialogTitle': 'Comment visibility', 'selectGroups': 'Visible to groups', 'selectOther': 'Other recipients', 'selectOriginalPoster': 'Original poster', 'selectModerators': 'Moderators', 'selectAssignees': 'Asked to answer users' }; pageContext.i18n.commentMenuLabels = { 'comment-edit': 'comments.menu.edit', 'comment-delete': 'comments.menu.delete', 'comment-convert': 'comments.menu.convert' };pageContext.i18n.answer= { bestAnswer: 'Best Answer', controlBar : { accept: 'Accept', unaccept: 'Unaccept', acceptCommand: 'Accept this answer as correct', cancelAcceptedCommand: 'Remove this answers accepted status' } }; window.croles = { u: false, op: false, m: false, og: false, as: false, ag: false, dc: false, doc: false, eo: false, ea: false }; tools.init({ q: { e: false, ew: false, eo: false, r: false, ro: false, d: false, dow: false, fv: false, c: false, co: false, p: false, tm: false , ms: false, mos: false }, n: { f: false, vf: false, vfo: false, vr: true, vro: true, c: false, co: false, vu: false, vd: false, w: false, wo: false, l: false }, c: { e: false, eo: false, d: false, dow: false, ta: false, tao: false, l: false }, a: { e: false, ew: false, eo: false, d: false, dow: false, a: false, aoq: false, ao: false, tc: false, tco: false, p: false, tm: false }, pc: croles }, { tc: true, nsc: true }); commandUtils.initializeLabels(); }); Skip to Content

F4 list of values not enabled in MDG CR for field "Units of Measure Group"

Hi Experts,

I have a requirement to add "Units of Measure" field (MEGRU) to Sales View of the MDG Change Request/UI (ECC6/Ehp5).

When I am adding the attribute ZZMEGRU and providing the data element MEGRU I am getting error "Data Model MM, entity type ZMVKE, attribute ZZMEGRU: Invalid check table"

So I provided the data element with data type CHAR4 it allowed me to create it and i was able to map it.  The field is also available in MDG CR but the F4 drop down is not enabled.

Please let me know what I am missing here.  I have tried to create a relationship for dependent table TWMEG but still it does not work.

Thanks in advance.

Regards,

Rama

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Oct 01, 2014 at 03:52 PM

    On simple solution (if possible from a business point of view) would be to define a ZZ-Dataelement with a ZZ-Domain and a Z-Valuetable, where the "Unit of Measure Group" is redundantly ( ! ) maintained. Can then be used in a Type3 entity with ref. relationship to your entity.

    Or you create an F4 help showing all MEGRUs from TWMEG and assign it to your CHAR4 field in the data model. This will provide at least a value help for your field, even though no checks.

    Regards, Ingo Bruß

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 01, 2014 at 01:53 PM

    Hi Rama

    Guess no value table for your custom data element? Try to assign TWMEG as value table 

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 01, 2014 at 04:09 PM

    Create an entity of type 3 with data element MEGRU. Then, create a "referencing" relationship to that entity in your type 1 or type 4 entity.

    Add comment
    10|10000 characters needed characters exceeded