Skip to Content

DTP selection not working


Hi experts,

I have a an issue with a DTP. When, the request is loaded to the DSO, i can see the following:

So i understand, that there is a filter on this DTP (selection conditions) : all the records that have a ZZGEST initial have to be excluded.

The problem is that i found in DSO some records with an empty ZZGEST, i checked the transformation, there is no treatment on that fields, only direct assignmet.

Can someone confirm that what i see in selection condition is what i understood?

If so, i am going to delete those records in end routine to be sure to not corrupt data.

Thanks.

Amine

Sans titre.png (10.9 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Best Answer
    Posted on Sep 30, 2014 at 02:58 PM

    Hi Mohammed and Karthik,

    I opened a thread yesterday on the following link:

    http://scn.sap.com/thread/3628093

    Unfortunately, i couldn't see what are the filters set on that DTP.

    Thanks.

    Amine

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 30, 2014 at 02:54 PM

    Hi,

    Go to that particular DTP and in the first tab check the filter option ..I mean what values are maintained there .

    Regards.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 30, 2014 at 02:54 PM

    Hi Amine

    Check the data once again the DSO. It seems you will have data only with blank ZZGEST. You are executing the DTP with ZZGEST = Blank.

    You need to exclude right. It should show ZZGEST (I/NE) ' ';

    Change the filter and try again

    Regards

    Karthik

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 30, 2014 at 03:01 PM

    Yes, your assumption was right, Need to exclude ZZEST which are blanks.

    Need to load the data from source except ZZEST = blank

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 01, 2014 at 08:54 AM

    Thanks a lot guys for you support.

    Amine

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.