Skip to Content
avatar image
Former Member

How to include a file (INL.H)

Hi community,

we try to include a .h-file by using EXEC SQL INCLUDE INL;  SQLPP gives error message "E2619 include file not found"; we've also tried to use the -I option for SQLPP, but this option is not recognized (help page is displayed when invoking with  -I).

Version:  SQL Anywhere Embedded SQL Version 16.0.0.1948

Many thanks for Your help.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Sep 30, 2014 at 03:35 PM

    Try EXEC SQL INCLUDE 'INL.H';

    Add comment
    10|10000 characters needed characters exceeded

    • Have you tried specifying the full path specification for the file? It may be looking in the "current directory" and that might not be where the file is. The message "file not found" is unlikely to be a bug in SQL Anywhere.

      What documentation are you using to guide you with sqlpp? The sqlpp -I (uppercase i) option is not documented and AFAIK never has been. In V5 there was a sqlpp -l (lowercase L) but that was for login userid and password.

      The reason for that question is this: If the docs for some other vendor's utility "like sqlpp" are being used, it may be misleading in other, even more important, ways.