Skip to Content
Sep 28, 2014 at 08:16 PM

Fiori Launchpad Error: Failure - Unable to load groups Resolved!!!!


Hey Good Fellas,

This is a solution rather than a discussion, which i thought to do to with a kind generosity of spirit to give back to the community.

It gives me immense pleasure and happiness to write this particular post, because it is through SCN only i have been able to find the solution.

Ok, let's get down to the Business quickly, shall we?

I have been configuring Fiori App - Approve Purchase Orders. All the tasks for this have been done from SAP Help Site.

Recently I upgraded the ERP/Gateway (Its an embedded deployment) to EHP 7 and UI to SP09, post which the Fiori Launchpad started giving the below error.

If you look around the SCN, you will probably hit across these threads and so did I.

SAP Fiori - UI Add-on SP09 update troubleshooting

With the first thread, I tried everyone's solution and suggestions which had worked for others, but it didn't for me.

With second thread (Excellently posted by @Masayuki Sekihara), it started off with lots of efforts and double-checks applying all of these notes hoping that it would resolve the issue. But I had done all the steps 1-8 and still didn't get the solution.

Besides the above two mentions I did umpteen number of other ridiculous things like implementing this note, that note, De-implementing another of the notes and everything i found as possible solutions on the Web.

Now, the breakthrough here is checking the errors in /IWFND/ERROR_LOG. Well, on the browser it used to give error 'Failure - Unable to Load Groups' while at the server side, actual error was something unusual and remotely not related to what the error looked like in the browser. In the back-end, I was getting the error "Data Provider implementation 'ZINTEROP_MODEL_0001_BE' '01' 'DEFAULT' does not exist". And this is something i know how to correct.

So just keep looking for the errors in /IWFND/ERROR_LOG and shift your focus there. That's really a good place to trouble-shoot.

And for the record to take care of the error 'Data Provider implementation 'ZINTEROP_MODEL_0001_BE' '01' 'DEFAULT' does not exist' you have to assign the DPC (Data Provider Class) to DMC (Data Modelling Class) correctly by navigating to IMG - SAP Netweaver - Gateway - Former Development - Local OData Channel Development - Registration - Assign Data Provider to Data Model. There you define the Data provider with the correct Software Version and Voila you are all set! You don't have to worry about the duplicate entry with another Software version, your correct software version is the one you have defined in the System Alias which you are using inside the service, which is generally DEFAULT.

I am able to get inside the Fiori Launchpad now (I was quite at edge to really give up as all the possible solutions had been ruled out for me 😕) and do see the tiles of the apps configured.

I hope this is going to be a good take-away for others who are having Odata handling issues.

The floor is all yours now for your kind feedback. Be gentle with me, I am a very shy blogger. 🤪

Best Regards,



pastedImage_16.png (22.8 kB)
Windows_8_1.jpg (72.9 kB)