Skip to Content
author's profile photo Former Member
Former Member

The parameter null error when previewing Dashboard

Hi Experts,

We're on SAP BI 4.1 SP03 patch 3 and I'm getting below error when previewing Dashboard. Can anyone have idea why this happening please?

Capture5.PNG (28.3 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • Posted on Sep 29, 2014 at 04:32 AM

    Seems like an issue with your Web Service. Check your web service. Which connection are you using, if you have used the Live office connection check your web service URL. Check the below Note too:

    1778610 - Error occurs: Null parameter session N/A 00000 when using Live Office connectivity


    If you are using BICS use the below Note to troubleshoot the issue.

    1801130 - How to troubleshoot issues in BICS Remote Web Service for Xcelsius/Dashboard Designer

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 29, 2014 at 08:45 AM

    Hi,

    Does the preview run for a long time before giving this error? It seems that the session expired while it was trying to preview the data.

    Regards,

    Shwetha

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 29, 2014 at 07:40 PM

    The error could very well be related with the session getting dropped.

    Try adding session.timeout parameter to dsws.properties file.

    Please review the below KBA:

    1917624 - How to increase session timeout for Web Service in BI 4.0 or BI 4.1

    Regards,

    Niraj

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 01, 2014 at 06:41 AM

    This issue happens with me as well. I have developed Dashboards on BICS connections and using Flash variables as well.

    Flash variables are to pass values from SAP EP to Dashboards as users view reports on EP.

    I get this error for the no. of BICS connections i use in my dashboard. initially i thought its an issue with EP but it was not. still the issue is unresolved for me.

    This usually happens when in a single session i refresh the report lots of times and also if i have a considerate time gap in between the refreshes. EP has a larger timeout hence i am able to refresh but seems my BICS interface is not able to hold that much parameters value or time period. i am still in contact with Admins to resolve the issue.

    As a workaround i have to clear the browser cache and restart the IE and then it works again.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.