Skip to Content
avatar image
Former Member

HTTP_SEND Performance Issue

Hi Experts,

I have a Proxy(SAP Backend) - PI - Web-Service Scenario that is having performance issues. The issue seems to occur in sending the request message.

When i examined the performance header of a request message, it seems HTTP_SEND step takes too much time(between begin and end steps) as it can be seen below(took 3 minutes). Also

Another example took 4 seconds.

An example from communication channel monitoring Audit Log can be seen below.

Seems there is a time gap that can be seen in marked area.

When i test the Web Service URL from SoapUI it takes like 1 seconds to get a response, but in PI the average response time is 10 seconds, this example took 3 minutes to complete.

What can be the reason behind this issue and how can it be solved? PI's version is 7.31.

Thanks,

Best Regards.

HTTP_SEND.png (12.1 kB)
HTTP_SEND2.png (16.6 kB)
Audit_Log.png (120.5 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Feb 02, 2016 at 11:55 PM

    Hi Faruk ,

    Did you find the root cause of the issue?

    We are facing the similar problem. Any information would be helpful.

    Thanks ,

    Dhanish

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 25, 2014 at 03:21 PM

    Faruk.

    What is the version of SAP PI ?

    Is it possible use the AAE concept ?

    Regards,

    BR.

    Ricardo Viana.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      Check whether it's the issue for network. Did you test the web service on SOAPUI from your local host? If yes, try that in your PI server.