Skip to Content
0
Former Member
Sep 25, 2014 at 07:47 AM

Global dependency deletion.

217 Views

Hello experts,

My problem is.

When I try to delete dependency using transaction cu02 I get message:

Assignments Still Exist for the Dependency.

Please Delete These First.

I try to check where-used-list using cu05 transaction and this list is empty. I've already tried to execute reports from notes 212477 and 604268, but result still the same.

I debugged both transactions (cu05 and cu02 deletion).

Before program delete dependency it checks records in CUOB table, if there are any, transaction gives message (see above).

When cu05 is executed it founds records in CUOB (CUOB-KNTAB = 'PLPOD' for all entries!) table and puts corresponding records in where-used-list table. Then checks PLPO-plnty field on cuob-knobj = plpo-knobj and if it equals 'N' or 'S' or 'E' then report will delete this records from where-used-list table and transaction show empty where-used-list.

So I found reason of my problems, but I don't know how to solve it. I tried to find appropriate sap note unsuccessfully.