Skip to Content

NWDS asks for OS User, deployment from NWDS fails

Hi everybody!

Since today, when opening NWDS (7.3 SP 08 PAT0004), after a few seconds I get prompted to "Enter your user name and password for ADM or another operating system administrator on the system host" in a dialog box titled "OS Logon to SAP JEE Host". There is no hint whatsoever which system host this refers to (local workstation with developer workplace or development portal or CBS or...). Whatever credentials I enter, nothing happens except that this box keeps on popping up. After clicking on "Cancel" for three times, the box does not reappear.

After that, when I try to deploy a DC to my development portal server from the Development Infrastructure perspective, I receive an Error saying

"Deployment failed, Error Code 0.

com.sap.ide.tools.services

com.sap.ide.eclipse.deployer.api.APIException: System TP2 not responding.

at com.sap.ide.eclipse.deployer.DeployerPlugin.getCurrentServerInfo(DeployerPlugin.java:94)

at com.sap.ide.eclipse.deployer.DeployerPlugin.getClient(DeployerPlugin.java:246)

at com.sap.ide.eclipse.deployer.DeployerPlugin.getClient(DeployerPlugin.java:218)

at com.sap.ide.tools.services.dc.EngineDcDeployService.deployFiles(EngineDcDeployService.java:255)

at com.sap.ide.tools.services.dc.EngineDcDeployService.deploy(EngineDcDeployService.java:135)

at com.sap.ide.dii05.ui.internal.actions.dc.DcDeployAction$5$1.run(DcDeployAction.java:282)

at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)"

When I deployed before, I got prompted to enter deployment credentials when starting the first deployment of the day, entered my own user-id and password and everything worked fine. My admin crew tells me that nothing has changed except that some weeks ago some pathed have been installed onto the netweaver portal server.

Does anyone have any clue on what may be misconfigured or what credentials have to be entered ?

Thanks

Michael

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    Posted on Sep 23, 2014 at 01:23 PM

    it is ask the os account of your nw system currently configured in your nwds

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 23, 2014 at 12:33 PM

    Hi michael ,

    can u please post what errors you are getting in error logs

    Regards

    Govardan

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 23, 2014 at 02:07 PM

    These are credentials of users who have deployment role/action in NW Java Application Server where code is to be deployed.

    Either get it assigned the same to your id or use administrator's id.

    --

    Regards,

    Amey

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 30, 2014 at 01:46 PM

    Ok, just to follow up on that:

    Obviously, my basis team installed a new kernel on the development portal server introducing some new security features. One of these requires authorization whenever NWDS requested diagnostic data, logs (ListLogFiles and ReadLogFile) or whatever from the NWDS default JEE server. The correct credentials would have been the <sid>adm user and password. As my basis team does not like to issue such data to the development team, the corresponding property "service/protectedwebmethods" in the default profile "DEFAULT.PFL" was changed from the default "SDEFAULT" to "DEFAULT". After that, the problems were solved.


    Thanks everybody!

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.