Skip to Content
avatar image
Former Member

SAP BI 4.1 SP1- Users unable to edit reports in favorites and Inbox

Hello,

We have installed SAP BI 4.1 SP1 in our environment.The installation was successful.

I have created a new group " test" and added few users to this group. I have given View on Demand,Schedule,View access level permissions to this "test" group in the Root folder(Manage > Top Level Security > All Folders)

Users are able to copy the reports to their favorites folder but they are unable to modify them. Modify option appears but on click on it the report again opens in the reading mode not in the design mode.

Please let me know what others permissions is required for the user to edit the reports in the favorites and Inbox.

Regards,

Pavithra

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Sep 19, 2014 at 02:29 PM

    Hi,

    You should provide access on web intelligence application.

    Right name: Web intelligence application >reporting-enable formatting

    I hope it will allow you to modify the report(Design mode)

    Thanks & regards,

    Ilayaperumal.A

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Pavithra,

      In 4.1 , a new Access Level was introduced Full Control (owner)

      So if you , See anything like this on Top Level Inboxes or Personal Folder

      Administrator -> Advanced

      Everyone -> Advanced

      These are teh default settings,

      If you view the security here,

      Administrators will have Full control and Edit and delete Objects will be denied. (hence advanced)

      Everyone will have Full control(owner) and Edit and Delete Objects will be denied. (hence advanced)

      Regards,

      RVS

  • Sep 18, 2014 at 03:56 PM

    Apply same security on 'personal folders' as well.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 19, 2014 at 10:56 AM

    Hi Jawahar,

    Thanks for your reply.

    I tried adding the same security on personal folders but it didn't help

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 24, 2014 at 05:52 AM

    On root folder assign "view" access to Everyone group

    On Sub folder remove all the access "no access" to Everyone group.

    Before doing modification, take a screen shot of current settings.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello,

      Please make sure that the issue is not occuring with the Administrator account to confirm that this is an issue with rights.
      You have to know that the predefined access levels View on Demand,Schedule,View cannot offer the ability to edit an object..

      Only the owner of the favourite folder should have full control access to his favourite/personal folder

      You may need to contact the SAP support for a better investigation.

      I hope this helps.

      Thanks & Regards,

      Insaf