Skip to Content
avatar image
Former Member

Async interface is executing as Sync

Hi everyone!

I'm with a problem here, I've developed an Async SOAP x Proxy interface.

The Interface is not complex, the both Services Interfaces (in and out) in ESB were configured as Async. The Sender SOAP is configured as "Exactly Once", and thats it.


But when I run a test through SOAPUI, the interface is being executed as a Sync! When I look in SXI_MONI, the QoS that it shows is BE (best effort).

And then a Mapping Error happens .. but it is caused because a Response messaging is being fired.

I tried to refresh the cache, did the scenario again, and nothing.

Does anyone knows what I'm doing wrong?

Thks!

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Sep 18, 2014 at 03:34 PM

    Eric,

    If the proxy is based on your Service Interface definition, then it should be happening. However can you share the WSDL information.

    I would check the Receiver SI mode (Assuming your integration is SOAP-->PI-->Proxy), and if required try to set it up with Fault Message Type and activate it again.

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 18, 2014 at 02:43 PM

    hmm..It should not..

    May be you can cross check the configuration again.. if you feel that you are referring to correct channel then do a dummy change and activate.

    make sure that the cache content is updated and then test.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Osman.

      A third party system will send some material data to the WS, and the data should be updated in SAP Ecc system.

      Unfortunately my user does not have access to test from RWB, the only test that I did in PI was the Test Configuration in Integration Builder .. and it was all ok

      I'm using SoapUI 5.0.0 as the SOAP Client to do the tests..

      thks