Skip to Content
avatar image
Former Member

Agentry Rule Editor Eclipse Not Working

I am trying to create a rule for a column in a transaction but the editor won't let me select any functions on the left hand side. In fact everything is disabled except for the tabs themselves.

I am using Eclipse Juno and I just updated to the Agentry 7.0.5 editor (included in SMP 3.0 SDK SP5). I had the same issue with the previous version of the editor as well.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Sep 18, 2014 at 01:11 AM

    Are you using the 32 bit version or 64 bit version?

    If yes, try the a 64 bit version on a 64 bit OS

    Are you using a Mac with Windows VM?

    If so, can you try on a Windows Machine and not on a Mac \ VM

    Stephen

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I'm using the 64 bit version on Windows 7. it is on a Mac with Windows VM. I tried installing the plugin into Kepler on a Windows machine and it failed. I will try it with Juno on the Windows machine tomorrow and see how it goes.

      Thanks,

      Dave

  • avatar image
    Former Member
    Nov 12, 2014 at 02:03 AM

    I also have had this problem.  I can not edit nor create a rule as all functions, properties, etc. are light-gray and inaccessible.  I have 64 bit OS with 64 bit version of eclipse, Juno, with version 7.0.5.7.  This is a major problem.  Is there a different, working version of the editor plugin?  Have you found a working set of versions yet?

    Thanks,

      Ed

    Add comment
    10|10000 characters needed characters exceeded

    • Ed,

      I am using 64 bit Windows 7 Enterprise Service Pack 1, Eclipse Juno Service Release 2, Agentry Editor Plugin 70.5.1.10.  This is a Windows laptop with no VM.  I have never seen the issue you report on any previous version of the plugin either.  My command line to start Eclipse is as follows: C:\Eclipse.Juno\eclipse\eclipse.exe -vmargs -Xms1124m -Xmx1124m -XX:PermSize=512m -XX:MaxPermSize=512m

      I do see other memory issues with these params though.  Periodic "Out of Handles" messages from Eclipse, screens and toolbars not refreshing as they should, etc..  When the Editor starts to act funny, I always do a restart on Eclipse and I am back in business.

      Jason Latko - Senior Product Developer at SAP

  • Mar 31, 2015 at 11:04 AM

    Hi Dave,

    Your application has an unnamed Global <<text.>>. You can either delete that unnamed Global or give it a name. Close open rule editors(if any) and re-open them, rule editor will work as expected.

    ~ Thanks

       Arun

    Add comment
    10|10000 characters needed characters exceeded