Skip to Content

Loading Stored procedure in sybase

Hi all,

I am trying to setup a backup for transaction log in sybase . I am refering to note 1588316 where script files are attached and the configuration scripts are given. I am able to take a database backup using sp_config_dump (stored Procedure) . Which is now scheduled in the DB13( DBACOCKPIT ).

But I am yet to setup transaction log backup which should happen every 30 mins as planned.

I am refering to the thread , Which describes a way to configure a script in SAPTOOLS . But when I try to load the file sp_dumptrans.sql using the steps described , I am getting some errors.

Please help me on this as I am new to Sybase . I am also attaching a screenshot of the error which shows up.

Thanks in advance

Regards,

Suratharajan .S

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Sep 19, 2014 at 08:42 AM

    Hello,

    net password encryption is enabled by default for the ASE.

    See SAP Note 1858378, just add -X at the end of your ISQL command and it should work.

    With kind regards

    Stefan

    Add comment
    10|10000 characters needed characters exceeded

    • Dear Stefan ,

      The encryption issue was corrected but , but i still have the issue with CT-LIBRARY error : (login failure )

      According to this article its a login failure SyBooks Online

      when i login using normaly with the below command

      isql -X -U <username> -P <password>

      The login is successful

      But when I try to import the sql script its unsuccessful . Is there any way to import the sql script sp_dumptrans.sql into the system ?

      Regards,

      Suratharajan

  • Sep 17, 2014 at 08:45 PM

    Run

    sp_helpserver SYB_BACKUP

    Does it show the status "net password encryption"?  If so run

    sp_serveroption SYB_BACKUP, "net password encryption", false

    and try your DUMP again.

    If the option wasn't on, or if turning it off fails to resolve the issue, please post an update.

    ASE and the Backup Server communicate via RPCs rather than by a login involving a password, so in theory this error should not happen regardless of the option setting (and it shouldn't matter if the option is on or off).  But I have seen a few reports of it happening.

    Add comment
    10|10000 characters needed characters exceeded