Skip to Content
0

Oracle JDBC driver on PI 7.3.1

Jan 25, 2017 at 11:57 AM

74

avatar image
Former Member

Dear All, Need to have Oracle JDBC driver (oracle version 10.2.0.4) in our PI 7.3 Ehp1 System which is on Sybase 15.7 database. Following few notes/ blogs but bit confused..

As per the blog https://blogs.sap.com/author/sumit.goel553/ I need to download SAP-XI3RDPARTY then extract com.sap.aii.adapter.lib.sda, add oracle driver according to JDK version..

my question is ..I need to check which systems JDK version?

1. Is it remote oracle server's JDK version or PI server's jdk version?

2. PI Server java version is ....is it the right way to check the JDK version or some thing else? hostname:pisadm 28> java -version

java version "1.6.0"

Java(TM) SE Runtime Environment (build pxa6460sr15fp1-20140110_01(SR15 FP1))

IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 Linux amd64-64 jvmxa6460sr15-20131231 _180656 (JIT enabled, AOT enabled)

J9VM - 20131231_180656

JIT - r9_20130920_46510ifx3

GC - GA24_Java6_SR15_20131231_1152_B180656)

JCL - 20140107_01

3. If I need to apply the Oracle JDBC driver based on PI 7.3 EHP1 Sybase server then I could not find the Oracle JDBC driver compatible to Java version(1.6) on Oracle site as given below. I am downloading third party oracle driver (Oracle 10.2.0.4 ) from http://www.oracle.com/technetwork/apps-tech/jdbc-10201-088211.html

4. Or I need to deploy Oralce JDBC Driver based on remote server which is having JDK 1.4 then is above given url is right to download the driver? As per the SAP Note 1590719..I should update the Oracle JDBC driver only throug sevice market place...but driver is not available at given path in sap note.

Kindly suggest

Thanks Sandeep

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers