Skip to Content
avatar image
Former Member

Unable to set up Search Connectors using TREX

Hello Gurus,

I am following the PLM Web UI config guide for the TREX setup. I am in the process of setting up search connectors for PLM objects ( Material/Material Plant/ Engineering Change Master) and I am getting the following error "Error while preparing".Below is the Log that I got for the error message. My basis team has updated all the latest version.

I followed the note 1957582 and did run the program even after that I am getting the same error message.

Kindly advice.

Thanks & Regards

Jo Pz

09/16/2014 13:22:14 Process Step: Preparation
Information Messages (1)
09/16/2014 13:22:14 Environment Details: TREX Version 7.10.57.00, Destination: TREX_RFC, SAP Release 740

09/16/2014 13:22:14 Process Step: Change inactive Connector Metadata
Warning Messages (14)
09/16/2014 13:23:10 Object type MATERIAL, node MATERIAL_PLANT:
09/16/2014 13:23:10 There is a field with the same name as the alias WERKS
09/16/2014 13:23:10 Object type MATKL, node MATKL:
09/16/2014 13:23:10 There is a field with the same name as the alias MATKL
09/16/2014 13:23:10 Object type ENGIN_CHANGE_ORDER, node ENGINEERINGCHANGEORD, request PLM:
09/16/2014 13:23:10 Request fields have been removed
09/16/2014 13:23:10 Object type ACCESS_CONTROL_CTX, node ACC_ADMIN:
09/16/2014 13:23:10 Node ACC_ADMIN has no response fields but is flagged for subquery
09/16/2014 13:23:10 Object type ENGIN_CHANGE_ORDER, node CHANGEOBJECTTYPE:
09/16/2014 13:23:10 Node CHANGEOBJECTTYPE has no response fields but is flagged for subquery
09/16/2014 13:23:10 Object type CLES_CLASS, node CLES_CLASS_LONGTEXT:
09/16/2014 13:23:10 Node CLES_CLASS_LONGTEXT has no response fields but is flagged for subquery
09/16/2014 13:23:10 Object type CLES_CLASS, node CLES_CLASS_NAME:
09/16/2014 13:23:10 Node CLES_CLASS_NAME has no response fields but is flagged for subquery
Error Messages (4)
09/16/2014 13:23:10 Rel. requests for object type CLES_CLASS, node CLES_CLASS:
09/16/2014 13:23:10 Navigation id 801CC4EFFE841DDEB7FE59BA4E4752F8 must start with $NAV_
09/16/2014 13:23:10 Rel. requests for object type CLES_CLASS, node CLES_CLASS:
09/16/2014 13:23:10 Navigation id 801CC4EFFE841DEEB7FE59BA4ED20D90 must start with $NAV_

09/16/2014 13:23:10 Process Step: Rollback
Error Messages (1)
09/16/2014 13:23:10 An exception was raised
09/16/2014 13:23:10 Error(s) occurred during connector creation
09/16/2014 13:23:10 Job cancelled after system exception ERROR_MESSAGE

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Sep 22, 2014 at 08:26 PM

    hi

    Have you run Z_MIGRATE_RELREQ_TNAV_NAVID

    (See note 1957582)

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 17, 2014 at 07:25 AM

    What version of ERP are you one? What version of Trex, and is installed for Embedded Search usage?

    espen

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 24, 2014 at 03:14 PM

    Hello,

        This error comes when the navigation IDs of subquery requests are not migrated correctly. then, the system issues the navigation error message.

    refer note 1957582 - SAP Note 1881679 is incorrect: $NAV_

    Basically, first you have to implement the code corrections.

    then manually you execute the report Z_MIGRATE_RELREQ_TNAV_NAVID.

    It corrects the incorrectly migrated entries.

    First, start the report when the test flag is set. If the system does not issue error messages, run the report without setting the test flag.

    Regards,

    Saravana

    Add comment
    10|10000 characters needed characters exceeded