Skip to Content

SAP doesn't start (only manually)

Hi,

What is happend: after a simple ST-A/PI update I restarted SAP (DEV). On an other system (QAS) I restarted the whole system. Just a simple restart .. not a bit of it! After the restart, I started the DB and tried to start SAP via MMC, but the MMC just showed the Process List and Access Points and SAP doesn't came up!

Windows 2008 R2 SP1

Oracle 11.2.0.4

SAP ERP 6.07 (nuc)

So I restarted the Service SAP<SID>_00, nothing changed.

I reinstalled it, nothing.

In the work directory the sapstartsrv.log shows the following entries, nothing to worry about:

---------------------------------------------------
trc file: "sapstartsrv.log", trc level: 0, release: "741"
---------------------------------------------------
pid 2660

[Thr 2744] Mon Sep 15 16:42:09 2014
HistoryLog_Init: logfile (D:\usr\sap\<SID>\DVEBMGS00\work\history.glf) already exists, check parameter
SAP HA Trace: SAP Microsoft Cluster library '741, patch 47, changelist 1517710' initialized
CCMS agent initialization: WARNING: cannot recognize instance type, checking profile parameter "system/type".
CCMS agent initialization for instance type ABAP: return code 0.
CCMS agent start: return code 0.
Initializing SAPControl Webservice
[Thr 2896] Mon Sep 15 16:42:14 2014
Auto PSE update thread started
Starting AutoRestart thread
SapSSLInit failed => https support disabled
AutoRestart thread started, version check is enabled
Starting WebService Named Pipe thread
Starting WebService thread
Webservice named pipe thread started, listening on port \\.\pipe\sapcontrol_00
Webservice thread started, listening on port 50013
SAP HA Trace: FindClusterResource: OpenCluster failed: 1060 [D:/depot/bas/741_REL/src/proj/sapha/sapwinha.cpp, line 214]
SAP HA Trace: SAP_HA_FindSAPInstance returns: SAP_HA_FAIL [D:/depot/bas/741_REL/src/proj/sapha/sapwinha.cpp, line 936]

swhsap\<SID>adm is starting SAP System at 2014/09/15 16:47:52
SAP HA Trace: FindClusterResource: OpenCluster failed: 1060 [D:/depot/bas/741_REL/src/proj/sapha/sapwinha.cpp, line 214]
SAP HA Trace: SAP_HA_FindSAPInstance returns: SAP_HA_FAIL [D:/depot/bas/741_REL/src/proj/sapha/sapwinha.cpp, line 936]


sapstart.log

SAP-R/3-Startup Program

Starting at 2014/09/15 16:47:57
Startup Profile: "D:\usr\sap\<SID>\SYS\profile\<SID>_DVEBMGS00_<HOST>"
Starting Programs


So I checked also:

- Environment variables

- Filesystem accessibility

- Windows Events

- reinstalled Redistributable Package

- Kernel Update 741.47

- MMC Update

If I start the SAP system manually, I get the system without any problems up:

D:\usr\sap\<SID>\SYS\exe\nuc\NTAMD64\sapcpe.EXE pf=\\<HOST>\sapmnt\<SID>\SYS\profile\<SID>_DVEBMGS00_<HOST>
D:\usr\sap\<SID>\SYS\exe\nuc\NTAMD64\strdbs.cmd <SID>
D:\usr\sap\<SID>\DVEBMGS00\exe\msg_server.EXE pf=\\<HOST>\sapmnt\<SID>\SYS\profile\<SID>_DVEBMGS00_<HOST>
D:\usr\sap\<SID>\DVEBMGS00\exe\disp+work.EXE pf=\\<HOST>\sapmnt\<SID>\SYS\profile\<SID>_DVEBMGS00_<HOST>
D:\usr\sap\<SID>\DVEBMGS00\exe\igswd.EXE -mode=profile pf=\\<HOST>\sapmnt\<SID>\SYS\profile\<SID>_DVEBMGS00_<HOST>


The strange thing is, after I don't find anything about it, I tried a restart on an other system and guess what, exactly the same problem!

No error messages in the logs .. and a manual start works.

I think the SAPSTARTSRV service doesn't start properly without any error messages!

So, does anyone got an idea? Maybe it's just simple and I don't get it. I just want to ask you before I open an OSS message ..

Thanks!

Best regards,

Tobias

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

6 Answers

  • Best Answer
    Sep 16, 2014 at 12:32 PM

    Hello everybody,

    After over 3 days of search, we found finally the main problem.

    During an EHP upgrade the SUM merged the start profile with the instance profile, so that all start parameters are included in the instance profile. On these two systems this merge process, I guess a bug in SUM, doesn't work. And the last SAP restart (during EHP upgrade) was over 2-3 month ago ..

    So, after a manual merge of the start parameters to the instance profile and a system reboot, SAP starts like it should!

    Thank you all for your help!

    Best regards,

    Tobias

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Wohh... this sounds crazy, but worked for me.

      As Tobias assisted, I copied my all parameters and added in the instance profile and restarted the box. Doing this, my SAPMMC issue ((there was no DB visible in instance and SAP did not start even though DB was up and R3trans was working)) was resolved and I was able to start SAP successfully.

      Thanks again Tobias.

      Regards,

      Prithivi Raj

  • Sep 15, 2014 at 03:43 PM

    Hi Tobias,

    May be you should add "service/protectedwebmethods = NONE" and try again.

    Also, delete the service and recreate it.

    Regards,

    Add comment
    10|10000 characters needed characters exceeded

    • Tobias Pätz Divyanshu Srivastava

      Hi Divyanshu,

      Firewall and Antivirus software, were the first things that I deactivated.

      Thanks for the notes, but I already read this notes step for step and found nothing.

      I will check it tomorrow a second time..

      I think it is not really a directly MMC problem, because on my client a have one with all SAP systems for an overview, which is not working. And the web interface (50013) is not working, too.

      Thought about a windows internal and sapstartsrv.exe problem, because the MMC sends the signal to start SAP, but the steps to execute the programs is always missing in the sapstart.log.

      The main problem is, I don't get more log files, or more informations .. I still searched the whole system during and after SAP start for the newest files.

      Thank you!

      Best regards,

      Tobias

  • avatar image
    Former Member
    Sep 15, 2014 at 04:02 PM

    Hi Tobias,

    Kindly paste the sapstartsrv.log , sapstart.trc , dev_disp and dev_w0 logs file.

    Also take a reboot of the server.

    With Regards

    Ashutosh

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Ashutosh,

      as you can see, I already posted the sapstartsrv.log.

      And I would post more logs if I have one, but SAP isn't starting as mentioned in the sapstart.log, so there is no dev_disp and dev_wX logs ..

      A reboot is already done, many times ;-)

      Thanks.

      Best regards,

      Tobias

  • Sep 15, 2014 at 06:12 PM

    Hello Tobias,

    The errors from the sapstartsrv.log can be ignored if your system is not clustered.

    Check SAP note 1929468 - SAP_HA_FAIL error outputed in the sapstartsrv.log on non clustered system

    If you have ASCS present then check the logs D:\usr\sap\<SID>\ASCS<NN>\work

    If not then are there any log files named stderr* ?

    Regards

    RB

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 16, 2014 at 09:01 AM

    Hi

    problem solved ?

    if not then please answer following

    1. whether you have cluster or not

    2. whether you can manually start the system not with MMC

    3. you have CI and DB on separate hosts ? if yes then check the listner process and telnet the listener port

    4. and your file systems has enough space .

    Regards

    Dishant

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Ruben,

      I would if I could, but I don't have a directory like this.

      Do you use a HA solution and/or DB2?

      If you see my log entries?:

      • SAP HA Trace: FindClusterResource: OpenCluster failed: 1060 [D:/depot/bas/741_REL/src/proj/sapha/sapwinha.cpp, line 214]
      • SAP HA Trace: SAP_HA_FindSAPInstance returns: SAP_HA_FAIL [D:/depot/bas/741_REL/src/proj/sapha/sapwinha.cpp, line 936]


      That's just an information .. like a warning, you find these entries in every installation, even you don't use HA.


      I hope you will find someone who can help you, or just use a sandbox to reinstall SAP to get these files.



      Best regards,

      Tobias




  • Jul 05, 2016 at 12:51 PM

    Hello,

    the solution worked for me too, but I had to make some more changes.

    I used the SUM 1.6 SP 16 (PL13) for an component upgrade.

    1. I had to delete and re-create the SAP Service for the ASCS<NR> because the Service used the 'old' START Profile Parameter. I changed it to use the ASCS<NR> Profile Parameter.

    2. I merged the Profiles, but in the SID_DVEBMGS<NR>_Servername Profile some parameters were missing. In the end I had to add the parameter rdisp/start_icman = true and everything went back to normal.

    Regards,

    Beni

    Add comment
    10|10000 characters needed characters exceeded